Automator action not working???

This is driving me crazy. Is it a bug or me doing something wrong?

Please take a look at the attached screenshot from This is supposed to be a simple Automator workflow which:

i) instructs OmniOutliner to export a document in opml format
ii) instructs DevonThink to import that opml document

All the steps in the workflow appear to be working well, but the very last step (“Add Items to Current Group”) fails.

Step #3 in the workflow (“Set Current Group”) yields the expected result because it indeed opens the selected group window in DevonThink. So the problem really seems to be with that last step…
:angry: :question:

Thank you.

PS1: I have collapsed the first two actions to fit the workflow in a single screenshot.

PS2: The warning that appears in relation to the first action seems inconsequential as the OPML document is exported as expected.

Is a DEVONthink window open during the last step? And what kind of windows/panels are open?

I’ve created a similar workflow (without OmniOutliner) and was able to import/index the .opml file. Which version of Mac OS X do you use?

Thank you for the response.

DevonThink is running and the main window is open. Also, the “Set Current Group” action succeeds and opens the “Dissertation” folder window, as one would expect.

I am running version 10.6.3 of the OS. :confused:

If this doesn’t work, would you perhaps be willing to share your own workflow with me, for debugging purposes? Thank you.

The test workflow consists of…

  • Set current group => global inbox
  • Get specified Finder items => Use an .opml file exported by DEVONthink (located in ~/Downloads but that shouldn’t matter)
  • Add items to current group

Incidentally, the problem seems more widespread. Here is another screenshot, showing that the same problem occurs with the “New Text Record” action of DevonThink.

How strange is that?

EDIT: I tried importing into the global inbox, as in your suggested workflow, but that produces the same error… I’m baffled!

Which version/edition are you using? Clearing the caches (~/Library/Caches) and restarting the computer might fix obscure scripting & Automator issues. Or has been anything logged to the system console?

I am using DTPO v.2.0.2. The console logs the following error:

6/10/10 5:25:37 PM[177]	([0x0-0x40f40f][9348]) Exited with exit code: 1

Unfortunately I cannot find this error code in the Apple documentation or elsewhere. Perhaps you could enlighten me?

Did this happen while executing the workflow? Then the process to handle the workflow crashed.

Yes, it happened while running the workflow. Interestingly, the “gear” icon on the menu bar keeps spinning indefinitely after the error is logged. But as soon as I click on the gear, it disappears from the menu bar.

So you are saying that “Automator launcher” is crashing?

Thank you.

Yes, the Automator launcher crashed and therefore the workflow wasn’t executed as expected. Did you try to empty the caches, delete the Automator preferences and to restart the computer?

Today I finally had the opportunity to clean all caches and reboot. I am sorry to report that the issue persists.

This is very frustrating—without its powerful scripting capabilities, DevonThink feels sort of crippled…

Any strategies for attacking this?


Could you send the workflows and the crash logs of the Automator launcher to cgrunenberg - at - Thanks.

Thanks again. You know, I am just realizing that the problem may actually lie elsewhere, namely in OmniOutliner. Here is why:

— I created an action consisting of OmniOutliner actions only (no DevonThink actions).
— Running this action from the Finder or from within the Automator works as expected.
— Running the same action from the OmniOutliner toolbar reproduces the bug (the “gear” icon keeps spinning on the menu bar, and the Automator Runner crashes).

I understand that the issue is not within your area of responsibility. My apologies for the false alarm—I should have checked earlier!

(Also, for some reason I can no longer find any console logs for the Automator Runner crashes…)

Some DT scripts (set the current group, Add Items to Current Group) are crashing Automator for me