Beachball when opening database after Force Quit

God help me. Maybe someone can see what I did from this police report.

I tried to eject two external HDDs. Nothing happened (i.e., icons still on Desktop). Tried again. Nothing. Brough DevonThink (DT) to front. Quit. Spinning ball. yep—the Force Quit dialog shows DT in red and “not responding.”

“Oh, DT stopped the eject, but the eject was queued, and then when I tried to quit DT, it couldn’t do something because the drives we no longer connected in some way.”

So what do I need to delete in order to be able to run DT and open my main database? (Opening it now leads to beachball → force quit → open DT → open database → beachball …


Where’s the database actually located? On the external drive? How long did you wait before using force quit?

Hello! Nope, it’s on my internal boot drive. But sometimes when I eject external HDDs, I get a warning saying that such-and-such program is using the drive right now. This time, I got no warning, but ejection did nothing. So I assumed DT must have something indexed from an external HDD showing in a window. So I tried to quit.

About two minutes.

Could you please launch Apple’s Activity Monitor application (see Applications > Utilities), select the frozen DEVONthink 3 in the list of processes, choose the menu item View > Sample Process and send the result to cgrunenberg - at - Thanks in advance!

Hello. It happened again but this time I let it run for an unreasonably long time and it eventually finished digesting whatever it was doing when I pulled life support last time. Sadly, I did not have the Activity Monitor running, and so did not capture that liquid gold, so now we’ll never know what it was doing.

It’s of course possible to launch this app while DEVONthink 3 is already unresponsive.