Best Way to Force Parity between DT3 and DTTG

In some of my groups in DTTG, there are numerous duplicates that aren’t present on in DT3. DTTG will show the correct count (48), but in the group there will be 92 files, with most of the files duplicated. However, when I tap into some of these, it displays “nothing selected” on a white background. Interestingly, though, if I tap a file and it shows “nothing selected”, then tap the other file that shows the contents, then tap back into the “empty” file, it will then show the same contents.

This is only a few of the main groups. I’ve tried running Verify and Verify Thoroughly on these databases, but it didn’t clear it up.

Would it be easier to reinstall DTTG, or is there another way to delete and re-download a database?

You could try this:

  1. Press the Help icon in the bottom toolbar.
  2. Go to Appendix > URL Commands > Performing Service Tasks .
  3. Press the Execute link under resync .
  4. Quit and relaunch DTTG.

Saw that on the DT board and tried it, but it didn’t work on either the iPhone or iPad.

I’ve compiled some images to show what I see in DT3 and in DTTG, in case that helps.

Try Criss’ instructions but use the delete-caches command instead. And note this will be rebuilt over time too.

Is this supposed to fix it immediately or rebuilt over time? Because it had no effect.

However, if there are actually files not present in both databases, you’d have a sync issue.
In that case, yes, you could try deleting the database in DEVONthink To Go and reimport it after the deletion is finished.

Wait… it did clear up. It didn’t resolve until the next sync cycle, even though I did so manually. Had them open here on the desk and they did something and now the dupes have been removed.


You’re welcome :slight_smile: