Bonjour connection times out despite using direct connection


I’m currently encountering sync issues using Bonjour, which appear not to be network-related.

Using a cable, the sync starts but consistently breaks off with “Connection to Server timed out” after 5-10 seconds. During this time, sometimes a couple items are synced but mostly it stays stuck displaying “item x of 100” underneath the progress bar without syncing.

Not knowing what might be useful steps, I tried disabling all smart rules and also disabling Little Snitch on MacOS (where I have added a rule to allow all DevonThink connections anyway).

Appreciate any input on steps I could try to get it to work again.

You didn’t mention you did this, so I’ll mention. See page 189 (3.9.2 version) of the “DEVONthink Manual” (also same in “Help”) for troubleshooting Bonjour synching. Might be a good idea lurking there.

Thanks. I had tried everything mentioned here except restarting. Did so for both devices, but the behavior remains reproducible.

Perhaps try with Wifi and Little Snitch disabled.

(Sometimes cables are faulty … happens).

I’ve had Wifi disabled on the iOS device to ensure it can only use the direct connection… and yes, Little Snitch is disabled.

However, perhaps this behavior provides a clue: After removing the Location in DTTG, it is once again available for re-adding. However, when I select it, there is an error message.

"General CFSocket error (AsyncSocketErrorDomain-1).

… and after trying a couple more times, there is a “Server busy” error message.

Edit: 10min later I was again able to add the Location.

Did you try using WiFi so as to see if it works? Cable might be culprit and that’s the only way I can think of to test that hypothesis is to remove it and try without–depending on software primarily (Apple’s Bonjour/systems and DEVONthink.)

The purpose of me to suggest disabling Little Snitch for this WiFi test is to take that out of possible contention, also.

Appreciate your thoughtful suggestions a lot @rmschne.

Well, I’ve now removed the cable, enabled Wifi on iOS device, disabled Little Snitch on MacOS, do not have a VPN running, restarted DTPO and DTTG… and am seeing the exact same behavior.

Probably @bluefrog will invite a support ticket so that they can look at logs.

that being said, I’d suggest one more idea: verify all the databases on all devices, rebuild if necessary, and empty trash on all devices.

Yeah, that would be great. Trash is empty on both devices, and I did a rebuild a week ago. The issue was present already beforehand, and it remained afterwards.

Verification on DTTG is something I never paid much attention to. After running it for my main database, there was a message saying that a number of files had incorrect pending flags set. And it started updating the parents and the grouping of a large number of items in the database.

However, while it completes updating the grouping and parents, there is never a “successfully verified” message. After running it again twice, it always does the same thing but it seems for whatever reason the database can’t be fully verified.

I searched above error message on this forum. A good hit from 2020 is

From this I was reminded about the requirement that Bonjour to accept connections be enabled on ONE device on the network. I have “Incoming Connections” enabled only in my iMac and Bonjour disabled or “OFF” on all other devices. Same for you?

Yes, definitely the case for me and always has been.

I brute-forced my way to a solution by reinstalling DTTG. Will take a while to get local files synced again but really no big deal in the end. I just hope this is a permanent fix.

1 Like

I suggest using a network monitoring tool like Wireshark:

But given that the error points to a socket error, that might not tell you much. What seems to be happening here is that DTTG can’t open a socket to connect to the Mac. Which points to a network problem, not a DT/DTTG one.

Did you check if a firewall is enabled on your Mac?

I think for whatever reason my dttg databases got corrupted beyond repair, see above. Verification never completed successfully even after repeated tries.

In any case, after reinstalling everything is syncing beautifully as per usual.

1 Like

I should have remembered that idea also!

Well, you did give the decisive hint nevertheless :wink: Thanks again @rmschne

  • Had you ever had Bonjour enabled on both devices?
    • If so, using the same Port?

Nope. I was aware from the start that it should only be enabled on one device.

Please open a support ticket if it happens again so we can see if there is anything useful in the logs.

Will do! Thanks.