Bonjour/Local Sync Store not working

I wanted to sync one database from my iMac to my iPad via Bonjour. So I followed the manual’s instructions, enabled Bonjour on both, set up the local sync store on my Mac, and enabled incoming connections on my iPad, but the database does not show up on the iPad.

I’ve rebooted, nothing. Also, the local sync store database is 12GB, but the one database I’ve synced to it is 6GB.

Am I doing something wrong?

Yes. Bonjour and Local Sync Store are two separate entities. Bonjour does not require a local sync store; with bonjour the devices sync directly from one to another. That requires bonjour to be activated on one device; on the other that location is then available on the local network.

Specifically: turn on bonjour on the Mac (provide a password). On the iPad the Mac will then be available under sync/locations/local network. You do not need to turn on bonjour on the second device (you could; if, for example you wanted to sync the iPad with the Mac, but an iPhone with the iPad, rather than the Mac)

1 Like

Thanks for the quick response. Still not working, though.

I’ve eliminated the Local Sync Store and enabled Bonjour on the Mac.

The iPad is on the same WiFi network as the Mac, but when I open DTTG, open Settings, I don’t see local network under Sync/Settings. Under Locations I see only Locations: iCloud … and Bonjour is Off.

An update: I tried using Bonjour to sync to my laptop, and it worked perfectly. I opened Preference/Sync on the laptop, and under Locations, there was my iMac. I selected it and it synced.

So my only problem now is how to get my iPad to respond to the Bonjour connection.

Do not enable Bonjour in DEVONthink To Go as you don’t need it.

In DEVONthink To Go’s Settings > Sync: Locations, it doesn’t show all available options if you’ve already added a location (and yes, that’s by design). Press the Edit link and you’ll see available sync options. The Mac should be shown there.

1 Like

Well that worked. Thanks to you and Blanc for steering me through. One question: why is not showing the options a design choice? It seems unintuitive not to see a possible location under “Locations”, but instead to have to click on a Location already in use (in this case iCloud) and then “Edit”.

While DEVONthink supports having more than one sync location, it is not intended as the default behavior. Especially on iOS, the experience is intended to be simple and straightforward.

I would just point out that this design choice made it the opposite of simple and straightforward. But I understand the desire to influence default behavior, and I appreciate the explanation.

No problem.

This conformed to the usual rules: I went to bed, had a good nights’ sleep and got up in the morning to find the problem solved :smiley: glad you figured it out (I wasn’t aware DTTG would only show one sync location/option, so I’m glad Jim weighed in)

By the way, Jim, I meant to ask you why having only one sync location is preferred. To save iCloud space, I’m using Bonjour for some databases that are large and that are less likely to need syncing when I’m mobile. I’m using iCloud for just those for which I’m more likely to need mobile syncing. I there a downside to having more than one sync location?

There is no specific downside, but it’s simpler when people only use one (and many people do).

Hi guys, new user here, so go easy :slight_smile:

I am also having a problem syncing via bonjour. I know Bonjour is working - few Macs round the house using it and checked using the Discovery app and can see DT. I’ve enabled Bonjour on my iMac, but when go into the edit locations on DTTG there is nothing shown? Obv tried rebooting iPhone and iMac.

1 Like

I’m not sure what the Discovery app is, but first step is to confirm all devices are on the same local network with no VPNs interferring, iPhones on Wifi, etc.

FYI, I just checked my iPhone and iPad. iPad working as expected. iPhone has the Bonjour greyed out. Why? Dunno. Have had it running for years. I also use WebDAV to my local NAS and CloudKit (for a couple of databases I’d like available in sync when I am at re-opened coffee shops), so with those alternatives I didn’t notice Bonjour off. Not something I normally monitor. I restarted the iPhone and upon this re-boot the device found DEVONthink via Bonjour. Running OSX 14.6. Apple must have changed someone along the way. A mystery. All well now.

Thanks for your reply and suggestions. I’ve done all of the checks. What do you mean “iPhone has the Bonjour greyed out.”? In DTTG? I’ve enabled Bonjour sync on my iMac and it’s off on the iPhone - I believe this is correct?

I mean as I said. I checked before writing to you that the connection via Bonjour on iPhone to my iMac was “greyed out”. Not good. Do not know why. So I restarted, and on restart was no longer greyed out and all working fine. Repeating, Apple must have changed something in recent updates or something. I have not a clue, and Apple provides few ways to debug on iPhone.