bookmark auto-load enable/disable option

Switching from Yojimbo to DT is quite an experience. One of these experiences is the way in which Yojimbo handles the viewing of bookmark items: When scrolling through a list of items – which may consist of things other than bookmarks – Yojimbo will display the item. No problem if it’s a locally stored document or web archive, etc.

Consequently, it plays really nicely – especially if you don’t have an internet connection – when displaying bookmarks: It only displays the metadata in the preview window. There are buttons to Open or Copy URL. Nice and simple!

On the other hand, DEVONThink assumes you have a network connection and will try to automatically display the page associated with that bookmark. Perhaps there are reasons as to why this behavior is automatic, but it is quite annoying when having to dismiss a dialog stating “No Internet Connection” every time you scroll onto a bookmark item.

So, I would like to recommend a Preference setting to enable/disable automatic bookmark loading. When disabled, a double-click or press of the Return key on the highlighted bookmark item should load it. Perhaps, when the item is highlighted, the metadata that would (normally) appear in an “Info” palette could be displayed.

Thanks for the opportunity to post requests. :slight_smile:

Thanks for the suggestion, we’ll consider this for future releases. In the meantime the only workaround is to use a view without a preview pane, e.g. icon or list view.

Any update regarding the option to “disable auto-load”?

There’s no such option but in case of an error DEVONthink doesn’t show an alert anymore.