Can’t remove ‘starred’ favorites from DTTG

Hi there,

I find I can’t remove some old favorites folders from the main Favorites folder in DTTG. These are ‘starred’ but I have no idea what that means, and how to remove the star. Can’t find a solution anywhere in the documentation or discussions. I must have added these starts in the past somehow, but no idea why or how.
Could someone please let me know how to remove these specific folders from favorites? Would be much appreciated.

BTW: it would be really helpful when favorites folders would sync in the next version of DTTG. Between both iOS and MacOS. And maybe even to the Files app main interface (that would be an ideal world.:wink: )

The stars ranking for items and groups appear in the Info pane for the item, so if you are looking at the list of groups in the Favorites smart group, select Edit, then select the group you want to remove the star rating from, then click on the Info toolbar icon (i in a circle) at the bottom of the file pane.

To remove a group from the Favorites smart group, as above select Edit, then select the group you want to remove from Favorites, then click on the Organize toolbar icon (looks like an upside down share icon) at the bottom of the file pane.

I don’t know about the Star rating in the manual, but searching for Favorites in the DTTG manual will explain in depth how the favorites work.

Thanks for the answer, but there are no star ratings in the info pane of DTTG-files as far as I can see. Only on MacOS. There’s no information in the documentation too. I have no idea what these stars mean, except that they appear to make it impossible to remove a file or folder from the Favorites smart group. When I follow the normal procedure to remove them from Favorites, there’s no option to ‘remove from Favorites’. I’ll add a screenshot of the situation.

A star in the Favorites indicates a group that has been favorited in
However, is still unreliable and buggy and does not always show Favorites properly.

Does that also explain why the menu doesn’t show the option to remove from favorites?

Thanks, I couldn’t figure it out and indeed saw all kinds of weird behavior when I started messing with favorites in Files app. This clears things up. So, like, @Greg_Jones, I assume is obstructing the removal of favorited folders from the Favorites smart Group within DTTG. That’s very weird…

It’s possible but @eboehnisch would have to weigh in on the technical details of that. has consistently had its Favorites not persist on multiple iOS devices of mine.

Just tried it here with a test group I had marked as a favorite in DEVONthink, made it a favorite in, and the remove from favorites command disappeared from the Organize menu.

What about a group you favorited only in
You should see the star in DEVONthink To Go’s Favorites smart group, but when returning to do you consistently see the group in its Favorites still?

Yes, exactly as you asked the question. As a result, setting a DEVONthink group as a favorite in appears to negate setting/removing a group in DEVONthink entirely.

The Favorites that you see in DEVONthink To Go are a mix of the favorites set in the Files app and the local favorites set in DEVONthink To Go itself. Technically, third-party apps cannot set or remove favorites in the Files app, therefore we use our own set and mirror-in the favorites from Files.

When you make a group a favorite in Files, you cannot remove it inside DEVONthink To Go. Or am I missing the point? :upside_down_face:

I don’t have any Favorites in the that are groups in DEVONthink to Go, which is why I didn’t understand the OP’s original question. I was just testing to confirm Jim’s question to me.

My issue right now is that I cannot remove a favorited folder in DTTG - that I originally favorited within the Files app - from the favorites smart folder in the Files app. It keeps popping up there after I remove it. Tried everything I could think off, but to no avail.
The only sensible thing I can think of next is to remove the whole database from sync, restart syncing and keeping my fingers crossed and praying to the almighty Apple in the cloud above.
So, the main lesson is: refrain from favoriting DTTG folders synced through iCloud within Files app. It’s a shame though, for this can theoretically be a good way to read and edit your DT-PDF’s in PDF Expert.

Thank you for the explanation, @MauriceB We’ll have a look why that is so.

It works fine here, perhaps test it now with iOS 14 installed to see if that makes a difference?

There are other, I’d say better, ways to open your DEVONthink PDFs in PDF Expert. You can use the share sheet in DEVONthink, or open them directly from PDF Expert.

In open them directly in PDFExpert, Greg. I don’t want a copy though, so i don’t use the share sheet. A working favorites group (through ‘files’, which i don’t open) will surely speed things up.

Fixed for the next release.

Looking forward to it!