Can we have bigger fonts for text in DTG?

I don’t understand the choice of font sizes in DTG. In particular, the font for web text captured as Markdown is too small for me to read or edit, making the feature almost unusable for me. I realise everyone’s eyes are a bit different, and so are tastes in presentation, but there is well-established typography rules-of-thumb such as not making lines longer than 65-70 characters if you want to them to be easy to read – but with my iPad Pro in landscape mode (the only convenient way to use it with the smart keyboard, I get 120-130 characters per line (with the sidebar visible – it rises to an impossible-to-read 190 chars/line if you expand to full screen)

I hope that either the default size can be increased or (perhaps better) users could choose their own font sizes for display and edit?

(I’d paste screenshots to illustrate what I mean if I knew how to do it on iOS)

Assuming you are capturing Clutter-Free Markdown, one thing you could do is add an inline style, like…

<style type="text/css">
body {font-size: 16px;}
</style>

However, the request is noted.

Why not just increase the font size in Preferences? (Preferences>Documents>Plain text size)

Or that too :laughing: :smiley:

Because it doesn’t change the size of the text font in Markdown documents?

(not for me, anyway)

Forget that – it does change the font size but you have to kill and relaunch DTG for it to take effect (not very iOS, but it works)

I’m not seeing that behavior here. Perhaps wait until the next maintenance release and try this again.

I don’t think you have to kill DEVONthink, but you do need to switch away from the current document to see the changes. In other words, try selecting a different document, even another markdown document, and you will see the change.

ah yes, thats all it takes. Sorry for sowing any unnecessary confusion!

No worries. :smiley:

This is a much needed feature request. I have an iPad (early 2018) and the text size is too small to be useful. The same is true for Markdown in Edit mode.

The iOS Dynamic Text Size feature does not work for me (iOS 11) in DTG.

Strangely, the size of the text on my iPhone 6s is not a problem. It is about 4 times larger than on the iPad!

Thank you.

Did you try changing the font size in DEVONthink to Go’s Preferences, as was mentioned above? That is all there is to changing the display size, on a device-by-device basis.

Thank you for pointing out to look in the app’s preferences. I had not realized that the preferences scrolled down to reveal more! I thought they meant the iOS preferences, and that didn’t work.

Now that I discovered scrolling down in DTG’s preferences window, I found it!

Thanks again!

Glad to help!

I’m just looking at this transition into DEVONthink, and have downloaded the iOS and MacOS versions. I was dismayed at the small size on my iPhone so installed on my iPad Pro thinking the larger display size works help, but it didn’t resolve the readability. The font is tiny!
I can’t really find an elegant solution and I know this thread is three years old. Is there an elegant solution to the small text that has emerged?

The answer to your question has already been given in this thread. Did you try it? Did it not work?