Cannot highlight certain pdf documents

DEVONthink supports Skim annotations stored in .pdfd files and stored in .pdf files via extended attributes. In this case the documents are opened read-only though. Converting them to a new PDF (see Data > Convert) should create editable documents.

AFAIK This has nothing to do with skim. I do know that DEVONthink uses pdfkit in a way that can scramble the text layer of some pdfs, (in my case these are notably ones that have been created by conversion in Calibre). I guess DT’s answer to the problem has been to turn off PDF annotation within DT for those PDFs. Better than ruining the pdf’s I suppose, but hardly satisfying, given that even Preview can handle these documents properly. It may be fair to blame PDFKit, but that doesn’t explain why DEVONthink seems to be the only reader that causes this scrambling.
I for one would like a fuller explanation.
Thanks,
Eiron

I am also seeing similar behavior, where the some PDF documents can be highlighted in Apple Preview, but the corresponding highlight controls are disabled in DEVONthink 3 for the same file.

It seems to depend on the specific PDF file, as there are files which I can highlight in DT3. Not sure what is going on (no asian characters in the impacted files either).

I am not using any 3rd party apps for the annotations (e.g., Skim or PDFExpert).

This is on DEVONthink 3.8 (latest) and Big Sur 11.6 (M1 Macbook Pro, if it matters).

1 Like

This might be the issue (for me, at least): the impacted files are encrypted (PDF eBooks).

However, Preview still allows me to annotate and highlight the content on these. See the screenshot from Preview with the Inspector open, and a sample highlighted phrase:

The highlighted entries do show up in the DT3 annotations pane:

Screen Shot 2021-10-17 at 8.51.28 PM

For me, at any rate, the source files are definitely not encrypted, so no explanation there, I’m afraid.

PDF files which might be corrupted are automatically opened by DEVONthink as read-only. The next release will add a hidden preference to disable this.

I have had similar problems and can often resolve them by using OCR to make a searchable pdf. Works most of the time.
Don

2 Likes

@dspady I just want to second your suggestion to use the menu item Data/OCR/to searchable PDF. I run into this “non-highlightable” issue fairly often, and the OCR almost always works for me too.

I have seen a similar problem and almost every time they were “protected” PDF files that cannot be altered or highlighted in any way. Some legal depositions are PDFA files.

Try to highlight and/or print with any other PDF app. If the highlighting feature doesn’t work anywhere, then you have a protected file.

Larry

1 Like

I have a similar problem highlighting in DT3 from time to time, which Bluefrog kindly found a workaround for - convert to PDF (Paginated): go to “Data” → “Convert” → “to PDF (Paginated)”.

It creates a new PDF (so I have to delete the old one) but the new PDF can be highlighted OK.

I don’t know if your issue is the same, but maybe worth a try if OCRing doesn’t solve it.

3 Likes

Same problem here: directly imported PDF via “Print to Inbox” cannot be highlighted. Have to "print "them again to inbox in order to highlight. @BLUEFROG , what can we do please?

1 Like

Which application and which macOS/iOS version did you use to print to the inbox?

I will check again in which cases this occurs. It is only in some cases!

@cgrunenberg I am having the same issue as well.

I am on OSX11.6 and used DevonThink 3.8.

This is not the first time that I am having this issue (not being able to highlights imported PDF).
I was searching the forum for a solution and found that thread.
I confirm that CONVERT > PDF (PAGINATED) solved the issue.

That’s a workaround and hope to see an update to solve that bug (don’t tell us it is not bug…).

Thank you!

1 Like

Welcome @mukei

It is a bug, just not a DEVONthink one. It’s an issue with Apple’s PDFKit framework, an issue they would have to fix. We are already employing workarounds for their bug but we can’t get around all of them.

@BLUEFROG thank you.
I went through other post after sending my message and understand better the situation.
Thank you for taking the time to reply.

I hope Apple provides a fix soon, but it seems to be an old bug they are not really urged to fix… :sob:

You’re very welcome and yes, we continue to hope Apple will fix these issues. Thanks for your patience and understanding.

Could you share more? Where can I find this preference?

I’ve run into these problems and have not been able to avoid them by using OCR to make a searchable PDF or converting to a paginated PDF. Thank you in advance!

See page 246 of the the user guide (also available through the in-app Help):

Note also the contents of the previous page of that guide which tell you how to access hidden preferences.

Stephen

2 Likes

Thank you @Stephen_C! I should have made the user guide and in-app help my first stops when looking for more info :blush: It’s working great now!