Read-only PDF document


I have a PDF document that I’m wanting to annotate, but it’s in Read-Only mode, and I can’t figure out how to unlock it. Clicking the Lock/Unlock button, changes from Locked to Read-Only, but not unlocked. I’ve also tried to change to Text Alternative but I don’t see that icon on this document, and pressing Command-Option-P results in a “beep”.

What can I do to resolve this issue?


Likely nothing in DEVONthink.
Either the original document is locked, has no editing permissions on the PDF, or has no write permissions. All of these would have to be handled outside DEVONthink.


It appears that you’re right, as I tried to annotate the PDF in PDFPen, and was denied because “permissions don’t allow”, and was prompted for a password to unlock it.


You’re welcome.

I have meeting the same problem, but in may case the file is not locked outside of DTP, I can annotate it with Adobe reader and when I save it the annotations appear in DTP. I could work like that, but I like to understand when something does not work.
I have checked the rights of the document: it was rw-r-r initially and I have changed it to rw-rw-rw but DTP does seem to change its behaviour, the file appears read-only.
I have checked the protections of the PDF file (File/Properties in Adobe reader), no visible protection here either, annotations are permitted.

Any idea why DTP thinks that this file is RO? And how can I change this?


1 Like

Thank you Pete. How can I check this? Adobe does not give any indication on potential corruption when I open or save the file and I can see all the text in the file, without any symptom of corruption.
When I save the file from Adobe, should it not become clean again? Why DT continues to indicate it RO then?

You can’t. AFAIK it’s a decision DEVONtech made in order to prevent potential corruption of PDFs that Apple’s PDFKit doesn’t handle correctly. It’s Apple’s fault, I think. Adobe doesn’t use PDFKit so you won’t see any indication there.

1 Like

That’s right but the next release will add a hidden preference to disable this.

This just happened to me and I came to this thread to find out what was going on. So then I went back and tried something. I did CONVERT>RICH TEXT and then took the result and CONVERT>PDF.

The conversion to RICH TEXT wasn’t perfect so the resulting PDF looks wonky in several places, but most of the running text was fine and that is what I am interested in annotating.

Simply converting the PDF to paginated PDF should also be sufficient, it’s not necessary to convert to rich text first.


This worked great, thank you.

Thanks for the follow-up. It’s appreciated :slight_smile:

It works. Thank you.

Welcome @erato

Glad to hear it worked for you :slight_smile:

1 Like

I had the same issue with a slide deck that wouldn’t let me annotate and picking Convert > to PDF even with a source PDF resolved the issue. I’m not sure if this could become a problem later though so I’m exporting the original read-only decks elsewhere just in case :man_shrugging:t2: so just wanted to confirm converting PDF to PDF resulted in a PDF I could edit/annotate.

edit: and thank you for that!