Cannot move files into a Group if the parent Group is tagged

Hello there,

I have been using DEVONThink in my Mac and DTTG in my iPhone and iPad for a few months already. It has not been until very recently that I noticed this strange behavior:

  • When I apply a tag to a Group, and this Group has subgroups (created before or after applying the tag), I cannot move files to this subgroup. A message appears saying “Couldn’t move file to this location”. This only happens in DTTG, both in iPhone and iPad. In Mac, everything works Ok.
  • I have tried applying the tag from DTTG and from DTOP, and the result is the same when trying to move the file from DTTG.
  • I have also tried creating the Group and Subgroup both from DTTG and DTOP. No difference.
  • I have tried to verify and check integrity of the DBs from DTOP.
  • I have tried in two different DBs, same result.
  • Both DBs are excluding group tagging.

I would bet I did not have this problem a month ago, but could not swear….
Currently using DTTG 3.6.1 in both iPhone and iPad.

Am I missing something??
Thanks in advance!

Thank you for the observation! This could be related to a performance optimization we made in version 3.6. We’ll follow your steps to reproduce the issue.

Thank you again, we should have fixed this issue for the next maintenance release.

Thank YOU!!