Cannot open-in-place Pages document

When using the share button to open a Pages document from DTTG, a new document is created in iCloud and this is what is opened in Pages. Thus changes made in Pages are not saved back to the document in DTTG. No one else seems to be having this issue. There does not appear to be a setting to control this behavior.

I am Using the latest iPadOS and DTTG and Pages versions.

How do I force DTTG to open the document in Pages that I want to edit and save it back to DTTG? Any ideas?

We can’t use the share menu
Instead, open the document via the Pages app, or the Files app

If you don’t see Devonthink as a location, you have to enable it in the Files app sidebar

I could be wrong, but I think this feature changed with the last release

[quote=“DTLow, post:2, topic:71745, full:true”]
We can’t use the share menu
Instead, open the document via the Pages app, or the Files app

Thanks! That solved the problem for me.

I didn’t have DEVONthink To Go enabled in the Files app, but as soon as I did, it also showed up in the Pages app. It’s disappointing that Share doesn’t work, but this actually may be better in the long run.

@DTLow’s suggestion is what we advocate as well.
However we do have a bug in the Share menu that will be addressed in the next release.


Hey Jim,

It’s been a while since I was on here but I’ve recently been experiencing a similar problem. However, unless I’m going nuts I thought this problem had been fixed ages ago in an earlier release? When I first started using DTTG the fact that I had to use this work-around to edit documents in native apps like Pages in DTTG (compared to how it works on Mac) was a real bug bear for me, especially as I have many, many layers of sub groups, of groups in each database, so locating a document in Files just to edit it is super time consuming. As a side note, is it possible to add a “Reveal in Files” option, so you can go direct to the actual file like we can on Mac?

Anyhow, my point is that I thought this old issue had been fixed long ago, much to my delight, but then recently I noticed that when I ‘opened’ a Pages document using the Share sheet option it was generating a new file name for the document (very long, looks like Hexidecimal) and, as @dwightb observed this is of course a new Pages document (not just a database generated file name for what we’ve called the file in DTTG). Did I just imagine that this had been fixed Jim @BLUEFROG or is this a recent problem that’s come up?



This is an issue in the current release and will be addressed in the next. Thanks for your patience and understanding.

Well at least I’m not going mad after all! No worries, it worked great before so I’m sure you’ll have it sorted soon enough :+1:

Stay tuned for more good things to come.

The share menu issue has been fixed in release 3.5.2

:+1: Fantastic, @DTLow! Thanks for the update. I just tried it and it worked for me. Looks like some other goodies in that update as well.