Cannot use "at"-character (@) in smart rule fields

I cannot enter the “@” character directly into a text field of a smart rule. But it works if I copy the “@” character from another app (like Notes) and paste it into the text field of a smart rule.

Using DEVONthink 3.7.2 on an iMac 2020 with Big Sur

I can’t confirm that behaviour; in the rule shown below, I was able to enter the @-symbol directly by using ⌥L (German keyboard layout; macOS 11.5.2, DT 3.7.2).

Usual question…: have you tried turning it off and back on again? :see_no_evil:

Like @Blanc I have success entering the @ character on a UK keyboard with latest macOS and DEVONthink versions. My hunch is that the issue is related to your macOS setup for the keyboard.

Thanks for your replies. It it really weird as it does not work here even if I try to enter “@” via the orginal macOS Keyboard Viewer. My keyboard works in every other Mac app but not in Devonthink’s text input fields (like smart rules, inspectors etc.).

The keyboard is a Logitech MX Keys for Mac.

Using the same keyboard over here without any problem. The “@” can be used in smart rules, inspector fields, and text.

I have btw. installed the latest version Logi Option + 0.42.692, as I switch the keyboard/mouse to three devices on demand.

Does typing @ into a plain text record work?

Thank you all for your replies. Now it is solved: “@” or ⌥-L was reserved for a KeyboardMaestro macro in DEVONthink. I changed the hotkey for the macro and now I am able to use the @-character again. :grinning:


Excellent and thanks for the diligence and follow-up! :slight_smile: