Can't connect to DTPO to dropbox

Hi everybody,

I have a new Mac and installed DTPO, but as I wanted to connect the new instance of DTPO to the Sync Store in my Dropbox, so I clicked preferences>sync and chose “new dropbox account” but nothing popped up and only a spinning wheel is occuring (see screenshot).

What I have tried so far:

  1. Reinstalled DTPO
    2.Reinstalled Dropbox
  2. Disconnected my other instance of DTPO with the sync Store - and the same Problem is now there too, same spinning wheel. (Only DTTG2 has no Problems with the syncstore)

Now I have rendered my Database on my iMac and Macbook useless - can somebody help? I haven’t used DTPO in a while, what am I doing wrong - or is there any other way to troubleshoot this authentification error (?) with dropbox?
I have tried the iCloud SyncStore - no problems there, but as I found out that DTTG could not access iCloud yet, I quit trying that because I use the DTTG quite often.

This could be simply Dropbox’s servers being unresponsive. In DEVONthink, hold the Option key and select Help > Report Bug.