Can't Delete Sync Location & duplicate sync location

I’ve been successfully syncing an iMac, MacBook Air, 2 iPads and an iPhone for quite a while. MacAir is on Catalina, iMac was on High Sierra, iPads one on 12 and one on 13 (can’t go get details on specific version if required and iPhone on 13.

I just updated the iMac to Catalina and now sync has gone totally weird.

I use a Synology NAS server with a WebDAV sync store. Looking at the location on the NAS there are now 2 different sync store files.
Note the case difference.

I tried to figure out which of the various devices was using which sync store but could not figure it out because all of them report the location just as asgard_sync. So I set all devices to sync manually only. Verified that I have the databases on my iMac and also a backup on an external drive that is disconnected. I tried to delete the location on the iMac so as to create a new clean one but right clicking on the location the delete is greyed out.

Deleted both sync locations off the NAS. Created a new sync location on the iMac and am slowly uploading all the databases. However in the preferences panel there is another greyed out Asgard sync WebDAv and I cannot delete it.

Plan is to slowly add devices back one at a time by creating a new WebDAV connection but I really want to get rid of the excess/old ones and I cannot figure out how to do that.

However in the preferences panel there is another greyed out Asgard sync WebDAv and I cannot delete it.

Those aren’t added by DEVONthink. WebDAV servers are detected on the local network and displayed. If they are inactive they will be displayed greyed out. Only disabling the WebDAV service for that location would cause it to disappear.

Well, not exactly true - I start adding let’s say WebDav location, but stop short and just cancel out of doing that. Despite the fact, I did not add anything the source is added to the greyed-out list of sources. Can’t delete it. I tried to start adding and canceled 4 times - 4 new WebDav sources are on the list now.
Does look very much like a bug to me. Devonthink v3.7.2
Also, the DTG v.3 often freezes on start-up. Restarting 2-5 times usually fixes it. Not great either.

1 Like

Click the checkbox to enable the sync location again. This is intentional so you can continue editing the sync location.

Regarding any “freezes”
When the application is stalled, do a Spotlight search for Activity Monitor. Select our application in the list of processes - it should show “(Not Responding)” and the name in red - and press Command-Option-S to run a sample on it. When the sample window opens, press the Save button and save it to your Desktop. Please attach this text file to your Support Ticket so we can inspect it.

I am sorry if it was not clear, but my Devonthink to Go (DTG v.3) freezes on IpadOS… I do not believe there is an activity monitor there

Ahh. Can you reproduce the freezing at will?

Basically, every time I try to start now it won’t start. I need to close the app, try again, close, and try to open again. Stops before iPad requires the touchID verification.
Usually opens on 3rd or 4th attempt…

On top of this I cannot get WebDav sync to work (worked on v.2) on DevonThink. Should I open a ticket for all those things?

Does the freezing persist after rebooting the iOS device?

If you’d like to open a ticket, please open a separate one for the sync and the freezing issue. Thanks.

Resolved WebDav issue, probably a local network configuration issue.
The DevonThink To Go issue is intermittent. Trying to find out when it happens more often. For now it looks like, that the issue is more persistent when the local synchronization is on, but the source is offline.
Changed to WebDav sync, will monitor. Also, the freezing issue is often resolved by pushing the home button to shut the iPad screen, and then re-initiate again. Strangely the DGT is not asking for password/touchID that way…

Glad to hear you have the WebDAV issue fixed!

If you have security enabled and switch and return to DEVONthink To Go quickly, it will not ask for authentication. There is a short grace period that allows for accidental closing or switching away from the app.