Can't download / sync since latest upgrade

Hi. I updated DTPO to 2.7 and I got this message in the log for each database:

“(Dropbox) Could not read the receipt. The receipt may have been created with an outdated version of the Sync Plugin. Please clean the remote store and try again.”

Could you please tell me how I clean the remote store?

p.s. I’m adding this text because I got a message from your forums that my message contains too few characters?

Same issue for every database that is sync’d through Dropbox.

After downloading the latest release, I am receiving error messages when attempting to synchronize with or download synchronized databases from Dropbox.

The databases on Dropbox were synchronized from a Mac running today’s latest update.

I have no soap or water to “clean the remote store.” In fact, I do not know what a “remote store” is, OR where it is.

This oblique jargon means nothing to me. It provides no useful instruction. :frowning:

With no helpful information, I am now precluded from accessing my information remotely. :angry:

The same error message also appears when the Global Inbox attempts to synchronize with the Dropbox mothership.

So, something 'taint right.

Appreciate guidance here.


1. Click the gear beneath the list of sync locations in Sync Preferences.
2. Select “Clean Location…”.

I’m getting the same error message for all of my DropBox-synchronised databases immediately after upgrading to DtPO 2.7. I don’t understand the message but hope “clean the remote store” does not mean erase it and sync all over again (across three Macs) when the thing was working just fine with the previous version. :frowning:

I’ve relegated 2.7 to the trash and returned to using 2.6.1 and everything seems to be working again.

On a related note, I don’t understand the advice given in the latest DEVONtechnologies newsletter:

That last paragraph about not synchronising the Apps folder in DropBox seems counter to my understanding of how DropBox sync works—wouldn’t it stop my databases from synchronising to all my other Macs?

A significant number of users requested encryption support. Unfortunately, this is something that can’t be supported with an option – it’s all-or-nothing.

I had been weighing it for a while, but Edward Snowden’s disclosures made a lot more people a lot more interested in this sort of thing.

This is not recommended; 2.7 fixes a number of bugs and adds several new features. It is, of course, your choice.

No. Sync’s Dropbox functionality doesn’t use the Dropbox sync folder on your machine. You don’t even have to have the Dropbox client installed.

Thanks for your quick response.

I’m not interested in encryption but I guess I don’t mind having it. Perhaps if the 2.7 upgrade forces complete refreshes of databases, with GBs worth of uploading and downloading as a consequence, it might be worth mentioning it in the upgrade notes.

That would be my fault; I’m poor at keeping my friends and coworkers apprised of the latest developments and their significance.

I’m sorry for the aggravation.

Unfortunately this didn’t resolve the issue. Still cannot sync…

Please open a support ticket.

I’m sorry. My mistake. I didn’t realize I had to do this for every database separately. I’m now cleaning location for my 3 databases.
Only the inbox was cleaned earlier…

I thought I had to select Dropbox sync location and clean location. Stupid of me, on the left side I also had to select every database. :blush:

Now sync is functional again. Thank you.

No problem at all. I made it a per-database operation so that it doesn’t disrupt other users (e.g. if your significant other is also using it to store his/her databases, etc). Another case where I fell down on documenting this. Sorry for the aggravation!

I had the same problem, was asked to “clean remote store” (something I would expect devonthink to do behind the scenes, or at least for the message to tell user how to do this). I found the preference and cleaned the remote store. Tried to sync again, kept getting follwowing error: Database Metadata: not found: error file has been deleted. I repaired and rebuilt database, same error. So then I went into dropbox app folder and deleted all the files to try to do a clean sync from scratch. Now it is giving an error on a partiuclar file, saying: Could not write the record’s content, server with the specified hostname not found. There is nothing wrong with my network connection. I have followed all the recommendations in the help and that I could find on here to set up dropbox sync properly. my devonthink database is stored locally. my dropbox apps folder is excluded from local dropbox sync. I have changed nothing about my database or computer settings; all I did was upgrade and I really regret it.

I have lost 3 HOURS of productivity with no end in sight. And something like this happens at least once a month that forces me to rebuild sync database from scratch.

I am very close to throwing in the towel on this flawed product. I have no use for it if sync isn’t working.

Please open a support ticket.

You should do a Tools > Verify & Repair periodically just to make sure your database’s integrity is intact. (I suggest weekly or bi-weekly for heavy use - just as a precaution. Also, observing regular backups with TimeMachine, etc is strongly advocated.) PS: This is not a Sync problem.

I can’t “clean” the remote database, because I have changed both of my local databases significantly since the last sync, and I fear that I lose some of those changes and get file duplications if I reset the sync like that…

EDIT: Jim pointed out to me that I was wrong about this. No, go ahead and clean the sync store. There’s no need to downgrade or do anything else. I was incorrect. I’m blaming it on a headache.

Im in a similar boat, sync failed and I ended up with thousands of duplicates. Support said to install new version (2.7) which I did and now I cant sync at all!

I have done a verify on all databases and no problems have been found on any I am trying to sync to my phone.

That’s a problem with the DT <-> DTTG sync. This thread is discussing DT’s sync functionality, which is completely different in every way. Please open a support ticket rather than commenting on unrelated threads.