Can't Empty Trash

I trashed a large set of indexed folders and they’re in the trash. However, I can’t empty the trash of these files. I have verified, optimized, and rebuilt the database two times now, and still cannot get rid of them. I’ve emptied the macOS trash, just in case, but still no. I’ve quit and restarted DT3 several times and just rebooted the Mac. Still cannot empty the trash.

I’ve searched the forum and the entries I’ve found are not applicable or are for an earlier version (and thus I’m not sure if the actions would still be appropriate).

Are some of the items locked? A screenshot of the alert after trying to empty the trash would be appreciated.

Well, I can’t get to that, as I kept looking for ways around this was able to move them. Although, the alert was telling the files were indexed and whether I wanted to delete Files, Files and Folders, or just In Database. I’m not 100% sure what the difference is between those buttons, but I tried all of them.

What I did was to create a new TEMP database and was able to move all of these to that temporary Db. This cleared out the Trash (yay!). There were almost 16GB of files.

Now all these files are in the TEMP database, should I just delete the database or move the items to the Trash and empty it?

If you actually don’t need them and the files are imported or moved into the database, you could delete the entire database. Remember that merely moving indexed items between databases does not move them into the database, i.e. import them.

Are you trying to delete the actual files in the Finder?

Thanks for the quick replies!

Now that I look at these files closer, I don’t think these were indexed, only replicated. I’m not sure how I got to the point I did, as I had done a lot of moving and adding at the same time, including having deleted a large bunch of files - some replicants and a few indexed.

I just deleted the TEMP Db and all seems fine.

You’re welcome :slight_smile: