Can't enter registration code

I got my registration code from Kagi, but I can’t enter it. When my trial period ended, DEVONthink (understandably enough) quit opening in my computer when it was connected to the internet. When I open it offline, the register button is dimmed out. What do I do now?

With the help of a geeky friend, we finally made it accept the registration code by taking the computer offline, then pasting in my name instead of typing it.

But the program is still acting strange – anything that requires it to be connected to the internet and do stuff makes it crash. For example, I enabled it start up when the computer is connected to the internet by telling it never check for updates (instead of checking each time it starts up). But choosing links from the Help menu that should cause it to visit the DevonTechnologies website instead make the program crash.

It also crashes when i try to import files, and when I tried moving the location of my database. Should I be taking these questions to some other support forum, or are they related to my difficulties getting registered?


Well, that all sounds pretty frustrating.   ???  I haven’t any idea why all that’s happening to you post-registration, without having happened pre-reg.

Have you tried downloading and installing a new copy of DT?  I’d do that first.  If that doesn’t help, I’d remove* DT reg file file (~/Library/Preferences/com.devon-technologies.think.registration.plist) from the enclosing folder, and try registering again with the newly downloaded copy.

*remove, don’t toss - you might need to put it back  :o

Definitely frustrating!!! And I’m noticing that our smiley selection is missing the one that banging its head against the wall…

Today I deleted my previous copy of DEVONthink (though it was 1.7.2) and removed all files it created in the previous registration: the database stuff and both of the com.devon-technologies.yadda.yadda files in the ~/Library/Preferences folder.  I downloaded and installed a fresh copy of 1.7.2, managed to get it to register by copy->pasting the info from the registration email…

But it’s still doing all the crashes I mentioned above. I think I’ll move this problem over to the troubleshooting area, since I’ve at least now gotten it registered…

Which Mac OS X version do you use?