Can't find or show Ulysses sheets in DEVONsphere

I was sure I was seeing Ulysses sheets when I first loaded DEVONsphere. Now I can’t though. I did, for no good reason, fiddle with preferences and settings. How should I have things set so that I can see Ulysses sheets when I search a term in DEVONsphere express? My Ulysses sheets are in the iCloud Drive and Full Disk Access is enabled.

Which version of macOS do you use and where exactly in iCloud Drive are these documents located? A screenshot of Preferences > Locations might be useful too.

Thank you for the reply. I have uninstalled and will re install in a day or so. I took Ulysses mostly off the iCloud Drive. Partly because I don’t need it there and can’t see it at all. I will get back to you if that is ok but I need a day or so with other things. Really appreciated quick response but I am trying a slightly different tack, I will see how it goes. I was sure I could see Ulysses sheets initially and I am hoping a reinstall will fix it…

I moved Ulysses from iCloud Drive. I did try to put the Library file they use in locations in the preferences on DEVONsphere. As well as I could understand it, so the app could search there. However I couldn’t see any Ulysses files in any search I did from DS. I am also getting two instances of every DEVONthink 3 file that shows, not other places like websites which only show once. I then re installed yet again. Exactly the same. However I have tried to place the Soulmen Ulysses location from the Library. I found it hard to do in the first place and it didn’t seem to show in the window on DEVONsphere. All my permissions seem to be right. I know one can never be sure nowadays there are so many. Disk access is there though.

Are you able to find such a file after saving it on the desktop and updating DEVONsphere Express’ index?

No I couldn’t find anything in the copied to Desktop File. I can actually only see backups in the only Soulmen file I can find in Library too. I don’t fully understand how they do it in fact.

I have to say I followed my own advice that I gave to folk the 3PV thread. Which is the fault is not in our stars but in ourselves. :rofl: Searchable Notes should be in DEVONthink 3 not Ulysses which I should be using for current and in progress writing and should have very little in it. I like Ulysses for writing but I find it is very inflexible and ‘proprietary’ in a way DEVONthink 3 isn’t. I am devising a prefix system for naming notes and dealing with this at that level. It would be nice to get DEVONsphere working though. I like it. Also at present it is showing everything in DEVONthink 3 twice as far as I can see. Soon I am buying a new Mac, this one is in need frankly of a nuke and pave, this is now 7 years of tranferred OSX. Here is what the search for a sheet that was in Ulysses looks like. No Ulysses but double copies of relevant DEVONthink 3 docs. There are a large number of relevant files that came up, none in Ulysses where several should have. I don’t want to consume too much of your time. Like I said I will soon be starting a new Mac. Maybe a couple of months.

I can’t remember if you had used DEVONthink 2.x with these databases previously.

Well yes and no. I had a lot of this on DT2 but I remade the databases on DEVONthink 3. I might have used the same name again by mistake sometime though. Are you thinking the old databases are still there somewhere? I can’t see them anywhere but that doesn’t mean anything. I had a zipfile copy in Documents too recently which I moved to a thumb drive. Everything is backed up on backblaze and two hard drives via time machine and I am guilty of over kill.

I am wondering if you are getting hits from Spotlight metadata for DEVONthink 2 an DEVONthink 3, which would both be present on the machine.

1 Like

I got you. I won’t worry about that so much, when I get the new Mac I will start it from scratch. Now I know what it is, it doesn’t bother me. Thanks you are right I checked and a document I added yesterday only showed up once. One part of the issue solved. I am not sure now if I need Ulysses to show on DS. However it might as well be able to see Ulysses? Any ideas? I am not going to sweat this unless it happens on the new Mac though. Then I would like it to work even if I don’t use it much. You never know, sometimes things show up you didn’t realize. That is the point of the app really? Thanks yet again :sunglasses:

I don’t see a location for the Ulysses documents in your Locations.

This was the best I could do and it doesn’t show any Ulysses files in DEVON sphere.

Can you find the Ulysses files with a normal Spotlight search in the Finder?

Yes I can.

I keep trying. Here is a screenshot of the Ulysses file in Locations to search. It updates as I would expect if I add a sheet to Ulysses, in other words I added a sheet today and the number went from 119 to 120 on that panel on the right.

However nothing shows on a search for a term. I tested it with terms I think should show. I show you how I have the ‘Categories’ set too. Did I do that wrong?

No those things appear fine.
The Ulysses format is not merely a Markdown document, IIRC. (I don’t use the app myself.)
It could be DEVONsphere isn’t using the Ulysses mdimporter.

Thanks again! I will ask the Ulysses people then and/or look for the mdimporter. I am above my knowledge really now? Thanks though. Anyway if those screenshots look right I know to look for something else!

Thing is really that I am sure it was working ok when I first installed DEVONsphere. That is what is bugging me. Showed the little icons right as well.

Could you please send a file that isn’t indexed to cgrunenberg - at - devon-technologies.com? In addition, which version of Ulysses is installed on your computer and in which folder?

1 Like

I will: thanks for picking this up. I will need a few spare minutes to do this. In advance I am on Version 18.5 (53991) and, as far as I understand it is in Applications folder. I looked at the Package there and the mdimporter is there. I am beyond anything I really understand now though. I did move my sheets from iCloud to the Mac at some point recently. For various reasons. I feel that around that time I had some glitches I must tell you. Otherwise I will do what you ask and go now to email.