Can't get RSS feed to display source webpage in-app

Most feed readers (like Feedly) have a setting so the full linked webpage appears in the content pane, not the 40-word short version. How can I do this in DT?

My workflow is now: click on my feed article, see a preview which doesn’t tell me much, click on the URL which opens safari, decide to save to DT there or not, then come back to DT. Then do this again and again for hundreds of feed articles per day. There has to be a better way, right?


1 Like

Set the Preferences > RSS to ano option other than Automatic.

This is also possible to do an a per-feed basis in Tools > Inspectors > Info > Generic > Format.

I tried this on a website that requires a subscription/login and if I set the option to PDF, the result from the RSS is a request to login. This happens even if I first log into the site while browsing a different article.

Is there any way for DT3 to automatically login in a situation like this?

Neither of these worked. I’m not getting the full webpage, just a summary. I tried all options. Other tips? Thanks.

Changing the preferences doesn’t affect existing items in feeds, only those added after changing the preferences. In addition, the command Go > Complete News and its shortcut might be useful too.

Thanks, Bluefrog! That works globally.

When I try your second per-feed choice, “Info” is grayed out. I’ve tried different feeds, articles, etc. but no luck. How can I make this work? Thanks again.

Thanks, cgrunenberg. I had been trying to make the changes happen to past posts. It all works well now globally.

Are you selecting the feeds or the articles?

  • You can’t set the Format on an article, only a feed.
  • The Go > Complete News works on individual articles, not the feeds. It also loads the linked pages. It isn’t converting them.
    They won’t be a feed article any longer, but you can use Script menu > Download > As… to convert selected feed articles to a chosen format.

Yes, Bluefrog, I’m selecting the feed and the Info / Generic choice stays grayed out. Oddly, I can click on the “i” in the upper right of the program and change the default there, but the menu item doesn’t work.

If you’re referring to this…

… that’s just a static header.

Ah, no, the word “Generic” is grayed out beneath it.