Can't open Database Mac M1 Devonthink 3

Good evening,
unfortunately, after restoring my Mac, I can no longer open the database email. I already tried to rename the .sparseimage file to .dtSparse, but that did not bring much success. The other databases all work. Unfortunately there are no entries in the log… Do you have any other ideas?
Thanks a lot!

I already tried to rename the .sparseimage file to .dtSparse, but that did not bring much success.

Was the database restored as a .sparseimage?

I think so yes. Im not sure, because I didn’t checked the folder after moving my backup to the new Macbook.

It’s likely a permissions issue.

Try this…

  1. Rename the file back to .sparseimage.
  2. Double-click it to mount the disk.
  3. Select the disk in a Finder window’s sidebar. You should see the .dtBase2 file there.
  4. Press Command-I to show the Info pane. . At the bottom, you’ll see Sharing & Permissions. Click the lock icon to unlock it.
    You will be prompted to enter your administrative password. (This is the password you use to log into the account).
  5. Make sure the account marked (Me) is set to Read & Write.
  6. Click the Action menu (gear icon) and choose Apply to enclosed items, if it is available.
  7. Change the extension back to .dtSparse.
  8. Double-click the file to relaunch DEVONthink.

I tried as you described. It looks like DT tries to open the Database as the icon pops ups for a sec. Unfortunately there is no change at “opened Databases” …

Is anything reported in Window > Log now?

unfortunately not … Window Log is Empty …

I had the same problem today and I just tried the directions from BlueFrog. Except, what I did was copy the .dtBase2 file, paste it back into my previous directory (the folder in which my other databases are stored, alongside the .sparseimage file), rename it (just to differentiate from the “lost” file, which still shows up in the "Recent Databases list in DevonThink in italics), and double-click it (after first closing DevonThink). This worked. What I don’t understand is why this happened in my instance, because I wasn’t restoring files nor backing up. I also had my permissions all clear and nothing had to be altered there (read & write were already granted). Hope this might help, Ft.Knorr…

1 Like

Welcome @Steve2021
Thanks for sharing your steps and experience. Perhaps it will indeed help @ft.knorr and any passers by.


@Steve2021 & @BLUEFROG Good mourning!
Thanks to Steve I am able to open my database again. So everything is finde. Just a further question. All the other databases in my folger are .dtSparse files. The one I copied from its original .dtSparse is now a .dtBase2. How can I get this to a dtspaöse file again, so all the databases have the same format? Thank a lot!

1 Like

Good mourning @BLUEFROG , do you have an idea about de dtBase2 and dtSparse files? Thanks a lot!
Best Fabian

Please open a support ticket. Thanks.