can't save as template +manually placed template doesn't sho

Having created a rich text file in DT (with nothing in it but settings for the paragraph to come), I cannot export it as a template (via Export / as template…): A log window opens and says “Failed” with no explanation. When I create an rtf and manually place it in the templates folder, it does show in the Data/Templates section, but when I have an new file created from that template file, this new file doen’t look like the template, and it doesn’t look like a default rich text either; instead, if the original file (the one I tried to save as a template in the beginning) is stil present, it contains a link that spells the name of that original file and indeed links to it. Once I delete that original file, another newly created one looks quite the same (generic typeface, no settings), and still contains the name of the original document, only without the link function. All this is the case whether the template file’s name is the same as the original document’s one, or not.

This doesn’t seem to make too much sense. Maybe my installation is broken?

Thanks a lot

You have to save the document first to apply the latest changes.

That’s indeed strange. Could you send the created templates to cgrunenberg - at - Thanks!

Just did, thanks. I sent the one described, and a new one of which I made sure it has been saved before being exported. Exporting works now; when employing the template, however, the result is a default rtf without any trace of the settings it should have.

Thanks, I’ve just received them.

Both templates seem to work as expected. If automatic wiki linking is enabled and is either using MashedWords or one of your documents is named “StyledRichText”, then the text is indeed linked. Otherwise it shouldn’t be linked.

The settings seem to be identical in DEVONthink and TextEdit. Which settings did you use and which ones are missing?

Indeed. I didn’t know about the wikilink function; I did see it, but it didn’t take it for what it is. Thanks for that one. And—I’ve learned something today: If I set a paragraph style in an empty rtf, these setting aren’t being saved and are therefore absent when reopening the document—or using it as a template. That may sound evident to almost everybody; it didn’t to me.
So, this is settled, and I thank you a lot.