Can't see remote iCloud databases

Hi, I have iCloud sync set up successfully in DT3. It is syncing between one personal Macbook Pro, an iPhone, and an iPad without issues.

I recently started a new position and am trying to get my work Macbook Pro to sync. The work Mac has JAMF on it to manage the device. I enable iCloud sync and enter my encryption key, but it never shows the remote databases. Sync is still working on my other devices.

I tried cleaning the sync store from my work Mac, adding a new key, using without a key, but nothing seems to actually sync to iCloud even though Devonthink indicates that it has.

I tried adding a new key and trying to connect to a new sync store in iCloud (I assume it would be new), but my iPad doesn’t see the remote database (it still sees the old original ones from the sync that is working) I created on my work Mac under the new key either.

Any ideas?

Under preferences, DT3 is enabled under apps that use iCloud FWIW.

Since I have no idea how DT3 sync works exactly, I’m having a tough time troubleshooting this.

Any pointers to detailed info on how DT3 sync works at the technical level or advice would be much appreciated.


Are any issues logged to Windows > Log? Did you use exactly the same encryption key on all devices?


Not that I could see. I tried using the same, different, and no keys. When using the same key and existing database syncs in iCloud, those remote data syncs never became visible on the Mac. When using a different key and a new database to sync, the Mac DT3 instance appeared to set the remote data sync correctly, but the remote data store never appeared on the iPad instance.

The keys have to be identical on all devices. Are you able to verify the sync store successful, see contextual menu in Preferences > Sync?

Yes, they do need to be the same to sync the same data stores.

I’ve entered the correct key and verified to no avail. The remote data stores never appear on this particular Mac.

So, I tried entering a new key and syncing a new database to see what would happen. When I did that, DT3 appeared to add the new database sync to iCloud, but that was not visible when I tried (with this new key) to add it in the iPad. I even cleaned it. So, just wondering how I could even be allowed to do that without overwriting the existing sync stores. I figured this might help me understand my real problem. No big deal.

This is why I am confused as I do not know exactly how the mechanism works. I was trying different things to troubleshoot, but without knowing how it works at a technical level, I am flying blind.

Basically, my problem is that the remote data syncs are not visible on one new computer that I have. I have a feeling this could be related to the JAMF management software on it, but I don’t know enough about the sync details to know. I do know that the sync happens on the Mac and then iCloud uploads the sync store data at its leisure. What I don’t know, besides the granular details, is what could be happening to cause these data stores not to be viewable on this particular Mac. My databases are stored under ~/Databases, DT3 is enabled under iCloud Documents, Desktop and Documents are not enabled under iCloud Documents.

Thank you for listening and trying to help!

Another detail which may solve the mystery.

I noticed that my iCloud folder in Finder never displays any files, it is not syncing. Could this be the reason that the sync does not appear to be working in DT3? The fact that DT3 is enabled under iCloud Documents preferences kinda throws me off here. Shouldn’t that be sufficient? Or, does the mechanism rely on the iCloud Finder folder functionality somehow?

DEVONthink only prepares the data for iCloud but the system both up- and downloads it on its own in the background. Depending on the size of the database and Apple’s servers you might have to wait before seeing the data on iOS.

iCloud Drive is not synchronizing your own files & folders? The iCloud sync data of DEVONthink doesn’t appear in the iCloud Drive folder.

The fact that the Finder folder is not syncing could be pertinent technically. I don’t know enough about the underlying mechanism, but somebody might. You’d have to know the low level details, more than is available in the documentation I’ve found.

I don’t think it’s a waiting issue as I’ve waited and the syncs appear elsewhere.

My sense is that this is related to the JAMF restrictions somehow.

DEVONthink’s iCloud sync is also handled via iCloud Drive. If iCloud Drive in the Finder doesn’t work as expected, then it’s probably the same issue.

My next step will be to reset syncing once I have access to my original Macbook again. I am in between locations in the moving process (what a time to be doing that, eh?!) and don’t have access to it for the next week or so.

I think you may be right. If it needs the Finder folder to sync, then that would explain it. The fact that I have DT3 enabled under iCloud Documents is what is throwing me off.

Meanwhile, I am able to sync using Bonjour from/to my iPad and that’s hooked up to iCloud successfully. So, I really do have to commend the developers on very robust and impressive sync functionality! I’ve always admired Devon Technologies and the quality of their code.


When you get situated and want to pursue this, you can hold the Option key and choose Help > Report Bug so we can discuss this off to the side.

Will do. Thanks!

OK folks, I solved the issue.

I confirmed with my IT folks that it wasn’t a JAMF or port restriction.

I then solved it by deleting my iCloud account from the Mac, rebooting, re-adding my iCloud account, and waiting 10-20 minutes for the iCloud background sync to work. Everything appeared in my iCloud folders and DEVONthink synced as expected.


1 Like

Glad to hear it and thanks for the follow up :slight_smile: