Can't seem to edit document properties

I read the Devonian Times tip on the Properties window: … seful-for/

However, I can’t seem to get it to work. I select a .pdf document and pull up the properties window. Hovering the mouse pointed over the author field confirms that the field is “only applicable to rich text and PDF documents”. I cannot seem to edit the field however! If I click on the space to enter text, nothing happens.

Any help appreciated.

Properties editing works as described in that blog entry.

If you can edit properties for a given PDF in another app, such as Acrobat, etc., but not in DEVONthink, then send a copy to DEVONthink Support (here or here or support_at_devontechnologies_dot_com). The forum cannot diagnose problems with particular files – that’s a task for individual Support.

To be clear, this is not a problem with individual files - this behaviour is across the board.

I took one of the files in question, opened it in Acrobat, edited the properties (added an author), saved it, updated indexed items in Devonthink and was then able to see the changes in Devonthink - but still not edit them.

I also wondered if the problem might exist because I am using indexing rather than importing, so I tried importing one of the files - but the same problem remains.

Any further pointers appreciated.

I’m seeing no issue here. As korm noted, please start a Support Ticket and attach a PDF or two as an example.

Thanks. Support ticket submitted.

Support are being helpful but after exchanging a few messages we still haven’t managed to solve the problem. Just thought I would mention here again in case anyone else has any bright ideas :slight_smile:

For the record, I just tried to edit the properties on about a dozen PDF and markdown files, some indexed, some imported, and was unable to do so on any of them. Tried on

No problems modifying those same files in other ways, such as annotating them, editing their contents, and so on.

(never found a need to modify the properties of files so this is the first I’ve noticed this, so I don’t know if it used to work and if this is a new development, or if this has always been the case)

Properties can only be changed on a document being shown in the preview window.

Bam, that’s it. I’m almost always in list view so this never occurred to me. Opening the PDF in DEVONthink’s viewer allows me to edit the properties.

I strongly suspect that’s got to be the issue for the OP.

Many thanks!! That was indeed it! Now why didn’t anyone say that earlier? :slight_smile: This is the kind of thing that would be helpful to have in the manual (or, even better, fix the app so that the properties can be edited without the file having to be opened in the preview window).

I don’t know if a fix is required because I don’t think anything is broken. HUD-like windows like the Properties window always apply to the currently-active document (or front-most and active window, depending on which HUD window is being referred to). Just selecting a document does not make it the active document (except in 3-pane view).

Then again maybe this behaviour needs to be re-thought? That said the logic is reasonably clear, (that is, unless you forget the logic, as I did). Documentation could help with this I suspect (as long as people read the documentation…)

Correction: Not quite. After looking very well to the DT3 view interface i saw a crossed over pen. My files are locked as it seems. Clicking the icon does nothing. Help files and take control are als not helpful (tc has 1 mention of the word locking). But DT3 has locked a 209000 files, about 2/3 of my files as read only. And as far as I can see lock is not in the metadata list, not on the flag list, not in the manual. Only in the context menu and in rules. You might want to warn people about the rule. I guess what happened is: I tried to use a rule to assign tags when files are placed in a certain folder. So it ran al the rules probably. Scope is a mystery for me in DT3 so far.

Having the same problem. I expected, as in another app I used before DT, to be able to edit document properties without having to open them in preview. Adding authors and proper titels is the main reason. Filenames aren’t that useful. But even if I do use preview DT3 (which I never do, I prefer native apps) I still cannot edit properties. I don’t want to create metadata “Author” and “Title” if it is already there. But if you can’t use it. :frowning: Metadata is metadata, some metadata is called properties. Other metadata is called, well metadata or annotations or … So what is the problem with metadata called properties. It usually is a mess, so editing it is not that strange.

What kind of file did you view? In main windows a preview pane is required.

PDF, Epub, etc. Some PDF’s let me change the title/author, others not. DT3 view can’t handle epub as it seems so you can’t edit metadata-properties. Most of the time you can’t edit metadata i.e. properties. Theoretically it should be set by the author when creating the file. But theory has nothing to do with what actually happens. And luckily for me, the titles/authors I changed using my old software are still there. But since DT moves the files I cannot use the old application to do the trick. It’s too much work anyway. Is should be nice quick and fast. Even the preview route is to long. Just found out that you can’t unselect the filename column. So I was amazed again. Setting columwidth is a problem and I want to see title/author full width so out goes the filename, or so I thought.
Btw I also checked on OS-level if the files are read-only. They are not. They are all readable by me, the user. Though some are 7 instead of 6 (700, 600, 660. The differences are probably a relic from my NAS. OSX-finder and NAS did not play well together.) So it is DT who stops me from editing. And sometimes not. I haven’t figured out why? The pesky xattr maybe?

Only the properties of PDF & RTF(D) documents can be edited.

Ok, thanks. Which begs the question why this choice? Well I figure something out. It only applies to the books and articles in my “library”.

The properties of images can be edited too.

Which begs the question why this choice?

It’s not “a choice”. It’s the supported metadata for those file types.