can't type.

Sometimes I get to a point where DT Pro doesn’t respond to my keyboard – i.e. I can’t type!

At these times, I am able to type in other programs. The fix is to quit and relaunch DT Pro.

Using 1.1.1, under 10.4.2.

Any ideas?



Do you use any input managers or spell checkers? In addition, please check if anything has been logged to the system console related to DT (see /Applications/Utilities/

You nailed it, I am using TypeIt4Me, and the behavior is actually happening as soon as I type an abbreviation at the end of a new entry title, then hit return – which should expand the entry. E.G. I have an entry which expands FA to “Final Art” when I hit enter. If I create a new Rich Text item called “do something with FA” and then hit enter, I want the entry to expand, but instead, DT intercepts the enter as an “Exit naming new item,” and I then get a message from DT saying “Do you want to delete the item?” I assume TypeIt4Me works by sending a command to delete the abbreviation and replace it with the expanded text.

I guess I could follow up with the TypeIt4Me developer, but hope there is a solution as I rely on both products heavily to cope with the data onslaught…

Good sleuthing and thanks again!

I just duplicated your issue. But it is specific to the return key. I use TypeIt4Me constantly with DT Pro, but not to create entry titles. I tried creating titles using other triggers, such as the space key and dash, and it worked fine, but of course you end up with an unwanted space (or other symbol) at the end of your title. But using the return key duplicated your results exactly.

So, you could use another trigger key to expand your title, but that may not be desirable.


Thanks for the info, and I should also say that I don’t really intentionally trigger the expansions. You know how it is with TypeIt4Me–one sort of forgets one is using it, and just type in shorthand. That’s why it took some prompting from Christian for me to be able to figure out what I was doing to cause it… The fact that it’s only the return key that causes the problem makes it less troublesome, I can consider turning that trigger off.

Glad it helped. Yeah, TypeIt4Me does tend to work on ‘automatic.’ It’s so wonderfully convenient we forget we are using it!