Capturing web to markdown yield a bookmark


Since the last version (3.6.2) I’ve noticed that when I try to capture a web on markdown (clutter free) I end up with a bookmark instead. This was happening before, but lately is happening much more. What is more, if I go to the DEVONthink interface and convert the bookmark to markdown usually DEVONthink is able to convert.

Perhaps something isn’t working as it should on the web capturer?


Does it work again after restarting the app or rebooting the computer? Which page did you try to capture?

This one for example: LG 27UK850-W: An Acceptable 27-inch Display for the Mac - TidBITS

I know that some sites are difficult to capture since it’s difficult to pinpoint which is the div that contains the text… but this is quite straight forward.

On this particular case, if I captured from Safari extension I got just a bookmark. If i try to convert (clicking right no the “note”) on DT I get another bookmark. But if I let the bookmark load and then I click right on the site and ask for markdown text capture, it works.

It’s really funny!

and if I try to do it now from safari… it works!! WTF! :flushed:

this could be something with devnothink’s default settings.


according to this, if you passed location as a parameter, devnothink will use download manage to download content which ignores your content.

by the way… I’ve notice this behavior a little bit more on the last version 3.7.2. Sometimes restarting the app helps, sometimes not… sometimes it’s really weird.

Is there anything we can do, besides restart and so, so improve the behavior of the capturer?

No, there are no new instructions for this.

Hi lpuerto

Using DT 3.7.2 & Catalina 10.15.7.
Was able to capture the md of the page with the Share button.

Did you try the “Share” button and “Add to DEVONthink 3” in Safari?

I’ve noticed this problem on some sites with a Login option since DT 2.
Maybe its code embedded in the webpages. Since Apple removed extensions from Safari, I now use Brave.

To get around this and other Safari workflow issues, I switched to the Brave browser with an md web clipper extension called “MarkDownload - Markdown Web Clipper”.

While on the webpage, I download as an md document to “DT Global Inbox” from the popup extension window. Most md extensions work this way.

Recently, I’ve been giving DEVONagent another go at being my research browser.

Take care

Yes… same result. AFAIK it uses the same script to capture the site.

By the way, it would be great if this can be fixed in any way, or at least you can give us a way to reset the capturing system. I’ve tried everything (close DT, Safari and force quit all the DT related processes) and I always end in the same place. Somehow after a little while the problem fixes and the site is captured as markdown and not as bookmark, but it’s a little bit annoying —to say the least— to try to capture something in markdown and yield a bookmark. I want a markdown document, even if it’s just the URL because something goes south, but not a bookmark.

What is exactly the problem? as far as I can infer, you download the page on DT and them you send it to site under to transform to markdown, and retrieve it as a document, right? The problem is the site or the web downloading?

yes and now… it seems that when it fails to create the markdown fallbacks to bookmark, which I don’t really like. I pretty much prefer to stick to the markdown even if it’s just the URL on it.

Does a conversion to Markdown (see Data > Convert > to Markdown) work or also fail?

Yes… I try in different ways (on other works from different places and menús) till it somehow gets fixed by itself, and then it work in every way. It’s really interesting.

I also try with different sites, just in case it’s just that site, but that is not the problem, because it fails also with sites that worked before (just yesterday).

It usually fails in the morning. When it gets fixed, usually work well the whole day. It’s pretty interesting.

PS/ I just go the bookmarket to save as markdown and let’s see how it behave in the following days.

is this site something to do with the conversion to markdown?

Yes, that’s our server handling the conversion.

I’ll try to check next time if I can reach it when the conversion fail… but I think that’s not the problem.

Anyhow, I think that it would be great if the conversion fails, it doesn’t fallback to bookmark, but a markdown just with an URL or something like that.

A smart rule could actually handle this.

If I try to convert the bookmark inside devonthink, fails again and creates another bookmark. The problem is not the clipper itself, is the converter. It doesn’t work —for some reason— and fallbacks to a bookmark :slightly_frowning_face: .

Right now it’s working like a charm, but I guess it will fail again tomorrow morning.

If this should happen again, could you please try to capture the same webpage using a different format without decluttering? Thank you!

I’ve tried and if my memory doesn’t fail, it worked. But yeah I can try the next time.

Do you think it’s the decluttering?

Decluttering is handled by the same server, therefore if both Markdown and decluttering do not work but other formats without decluttering work then it’s definitely a server issue.

1 Like