Changed tag behaviour?

Ho hum… I have a problem with DT 3.7.2 that may be of my own making, but is nevertheless vexing.

I have all my payslips, P60’s (I’m in the UK), tax returns, HMRC correspondence etc saved in groups. To pull together everything for a given financial year each document is tagged with a tag like FY 2019/20, including the space and / characters. This has worked since I first purchased DT, quite some time ago. However, trying to tag a document for FY 2021/22 I find that the behaviour has changed: two tags – FY 2021 and 22 – now get created. It looks OK when I type “FY 2021/22” into the tag bar below the Document preview, but when I go back later it’s changed. I also now see in the Tags section of the navigation column the tag FY 2021 with a disclosure arrow that, when opened, shows 22.
My supposition is that somewhere along the line DT has introduced nested tags and / is now a special character designating a delimiter.

I’m not saying that nested tags aren’t a good idea, but it’s rather scuppered my tagging (from FY 1998/99 onwards!). So, is it possible to escape the / character when entering the tag name? I’ve tried using / as an escape sequence (in the usual Unix style), but that doesn’t work. Alternatively, is there a preference somewhere to change the delimiter? I know Unix uses ‘/’, but Windows uses ‘’ and sometimes you see ‘:’ in path names, so it’s not like the use of ‘/’ is universal. Finally, are there any other special characters I should know about? If I’m going to have to change all my financial year tags to a different format, I don’t want to find that the separator character I choose (-?, ~?, ****?, :?) has equally awkward side effects.

Thanks for your help on this.

Freudian slip – the title was meant to be Changed TAG behaviour!

That’s correct, an earlier release of DEVONthink 3.x changed this some time ago. One workaround is to create the tag first inside the Tags group, afterwards you should be able to enter & apply the tag as usual.


Thank you, the work around you suggest fixes my problem. Tag groups also look really useful in simplifying the otherwise long list of tags that I have.

1 Like