Check grammar bug

  1. Create a markdown document and enter some text.
  2. Uncheck Spelling and Grammar > Check Grammar with Spelling.
  3. Switch to Document Display > Preview.
  4. Switch to Document Display > Source.
  5. The Check Grammar with Spelling option is ticked again.

Please fix.

This is a setting in Preferences > Editing.

Thanks. Works as expected now. This is very non-standard UI behavior IMHO. Excepting some very funky applications, a checked item stays checked until unchecked and vice versa.

It’s IMHO identical to e.g. TextEdit.

It is indeed the case in TextEdit when you toggle the status in the menu, close the file and then reopen it later (which is debatable from a UI perspective but that’s Apple fault). However, in DT it’s very confusing when switching from source to preview and back again, without leaving the document. You’re editing, then having a brief look at the final result, then back to editing and bam, a setting’s been changed. At least now I know what’s happening so I can live with it, but it’s not very intuitive IMHO.