CKerror domain 15


During my holidays in mid-august it seems that my sync through iCloudkit stopped running.
since then I get the CLerror domain 15 each time I try to sync my DBs
I know that this error should be linked to Apple’s servers but I am wondering if in that case of so long time error it’s really the root cause
Any suggestion to restore my sync please (I tried through Bonjour over Wifi without success and tried with USB-C cable same result nothing :frowning: ) ?
Many thanks


Apples sync services known to be unreliable. Have you turned it off?

Did you set up the Bonjour exactly as instructed in the DEVONthink Manual, page 61 of the 3.9.2 version? Also review Bonjour Simplified

What was the error messages when hooking up Bonjour?

Also I recommend you do a verify and repair on all the databases, and empty Trash.

Finally see the section in the DEVONthink Manual on troubleshooting sync issues, page 188 of the 3.9.2 version.

I turned off iCloudkit (there is no location selection now anymore)

On Bonjour set up I think I did it correctly by activating it on my iMac which is the server where are located the DBs to sync with my iPad ?

Currently looks like nothing happen at all in this config (I tried with and without USB-C cable) and Bonjour up so no error

I tried to do a verify and repair on one of my DB on my iPad and on my iMac nothing changed


odd. Please provide screen shots of the sync screens on Mac and iPad.

Also is your network setup correctly?

And was there anything in the trouble shooting or other documents that showed anything ?

I turned off iCloudkit (there is no location selection now anymore)

  • Are you using a shallow sync in DEVONthink To Go, i.e., Download Files: On demand?
  • Does the Mac have an intact and healthy copy of the database?

Hi There

Looks like I found the origin of my Bonjour sync blocking

Actually I wasn’t connected to my iMac Bonjour server due to wrong password I put on the connection to iMac local set up over the Wifi :slight_smile:

Once entered the iMac Bonjour password on my iPad Wifi local connection I was connected to my iMac and then I could do the sync of my DBs

Thanks for your reply it help me to understand the root cause of this error

And at the moment I won’t try anymore iCloudkit too much trouble