Clip from Chrome not working

Hi all -

I’m using DevonThink (latest version) with Chrome Version 20.0.1132.57.

I’ve installed the boomarklet, and when I click on it in Chrome, I get a dialog asking for the type of save to do (Web Archive, PDF, etc). I fill out the Note and hit OK, but nothing ever shows up in any of my Inboxes or anywhere else that I can see in DTPO.

Any words of wisdom? Thanks…

Same version of Chrome over here – the Chrome extension works as expected.

The bookmarklet or the extension (DEVONthink > Install Add-Ons …)?

The “Note” is optional - but using it or not using it shouldn’t affect the extension.

Uninstall the extension in Chrome > Preferences > Extensions, clear Chrome’s cache, and reinstall it from the DEVONthink menu mentioned above.

Thanks -

I did as you suggested, and the import worked - exactly once. Then stopped working again. I’ll try reinstalling and clearing cache again. Very frustrating.

The Chrome extension only clips a given web address once – which is annoying. If you move on to another address the clipper should work again.

Yeah - I noticed that. But the issue I’m having is that I click on the DTPO extension, I get the dialog, the focus changes to DTPO, but nothing ever appears in the Inbox or anywhere else I can see. Its like the extension fires, but the import fails, which is concerning because you THINK you’ve captured something when you really haven’t.

A couple additional data points. I tried rebooting, and then I COULD clip once from Safari, and once from Chrome. Then it seems to get “stuck”. If I have the activity window open, I can see it “downloading” the URL. It just doesn’t end up in DTPO anywhere.

Are you certain the capture wasn’t sent to the location defined in DEVONthink’s Preferences > Import - Destination? Try this: Set Preferences > Import - Destination to “Select group”. If the capture was made, you should see a HUD that allows you to choose any group in any open database as the destination.

Comment: I almost never want to capture an entire Web page, because that often includes extraneous information (text and images). My preferred captures are rich text or WebArchive of a selected area of the page that contains only the information of interest.

These captures use Services. The keyboard shortcut to capture as rich text is “Command-)”. The keyboard shortcut for capture of the selected area as WebArchive is “Command-%”.

Excluding extraneous material, improves the effectiveness and efficiency of searches and the Classify and See Also assistants. In many cases, the resulting file will be much smaller than if the entire page had been captured - sometimes by one or two orders of magnitude.

Safari’s Reader button is a convenient way to select the primary information on a page, such as an article, as a rich text view. Select that view by pressing “Command-A”, then press “Command-)” to capture as a rich text document.

Because Chrome and Firefox don’t handle OS X Services well, I avoid using them when I wish to capture data from the Web to a DEVONthink database.

Thanks. I’m getting very strange and completely non-consistent results.

I changed the Preferences - Import as you recommended. Even when the Clip window would come up - it would never be followed by a location dialog. It just plopped the clip into the Global Inbox. I checked the setting several times, and it is set to “Select Location” as I want, but it never ASKS for a location.

Secondly, Command ) and Command % don’t work at all for me - I can highlight text and select either key combination, and nothing happens in the activity window and nothing gets clipped to DTPO.

Finally, as before, when I CAN get the clip to work, it works once, and only once. From that point on, I will never get the clip dialog in either Chrome or Safari.

Those Services keyboard shortcuts will work in Safari (as I noted), or in DEVONagent Pro or DEVONthink’s internal browser. Don’t expect them to work in Chrome.

If they don’t work in Safari on your Mac, your computer may be a bit addled. Try a restart to see if that helps.

This does not work for me either. I’m demoing DEVONthink 2.3.5 and have Clip to DEVONthink 1.2.1 installed in Chrome 20.0.1132.57 on MacOS 10.5.7.

First clip worked and appeared in the Global Inbox as expected. After that, it simply won’t work. I’ve tried the suggested uninstall/reinstall of the Chrome extension to no avail. Something seems broken.

One item of note – when this happens for the 2+ attempt to clip a new unique URL from Chrome, it causes an odd error:

  1. Open new tab in Chrome and open a new page never clipped before.
  2. Right click on the Clip to DEVONthink icon in the Chrome toolbar and select the first menu item “Clip to DEVONthink”.
  3. Instead of the grey dialog coming up as expected, it opens a new Chrome tab with the URL “” and shows the following error:
    2012-07-22 07.46.16 pm.png
    Please advise.