Clip to DEVONthink extension in Chrome

I have always used this plugin without problems, but it has been a few days since, if I try to use “Clip to DEVONthing” in Chrome (Version 84.0.4147.89) I got a warning “Open DEVONthink 3.App?” (see screenshot attached). If I click OK then DEVONthink open and everything works well. But this happens for every site where I try to use it. I have already tried to uninstall the plugin and reinstall it but it continues to happen.

Has anyone already happened and managed to solve this problem?


  • Marco.

Screenshot 2020-07-18 at 10.09.37

This sounds similar to this issue for which nobody could find an answer other than to check Permissions in Catalina:

I solved it by using the Clip to Devonthink Hotkey instead of the bookmarklet:

This would be a Chrome question. We have not changed the plugin recently.

Thanks, creating a Hotkey is a nice workaround.

Thanks, I understand. Hope that future releases of Chrome change this…

At your risk (see discussion and warning from Devontech staff) CleanMyMac may work to fix this - it worked for me: