Clip to DevonThink in 2.1 popping up in Safari unnecessarily

Hey all;

I installed the update of DT Pro 2.1 this morning, installed the new version of Clip to DevonThink and for about forty-five glorious minutes everything worked as it should. It gave me the pop-up window when I wanted it to and not when I didn’t.

Then it started its old bad behavior. Every new page load now causes the pop-up for clip-to-DevonThink to display. I reset Safari, flushed cache, history and cleared out the extension. It’s still giving me the same issue.

Is there a .plist file I can edit or something? Is it possible that some part of the legacy clip-to-Devonthink hung around?

Any suggestions are welcome.


You might check if the old Clip to DEVONthink extension for Safari is still installed. It was for me after the DtPO 2.1 update.

I’m having the same issue ! :confused:
Already tried to remove everything and re-installing… no sucess !

I am having an issue, as well.

If I drag text from Safari 5 into the sorter, no troubles.

If I invoke the services keyboard shortcuts for web archive or rtf, no troubles.

If I try the clipping button in the toolbar of Safari, after having selected text, I get the selection window, but nothing shows up in DT.

I did have to uninstall the original extension, but it sure appears that the new extension is the current one.

Same here. Selection does not show up. If I clip anyway, the whole page gets clipped.

I’ve got the same issue. Selected text does not get carried over into the comment field of the DT plugin.

I have had this same problem ever since I installed DevonThink last year. I was hoping 2.1 would fix it, but no dice.

I see that this post was started four days ago and there still hasn’t been any response from Devon. Is this typical? I’m also having the problem with the Sorter disappearing that others have noted.

I’m thinking more and more about switching to Evernote.

Hello all,

Re: Clip to DEVONthink showing up when it oughtn’t, please check the extension’s settings in Safari’s Preferences, under Extensions; is the shortcut enabled? If so, try disabling it; does it work now? If not, please email me at and I’ll try to figure it out with you one-on-one (and post back here when I’ve got it sorted out :slight_smile: ).

Re: the selection not being pulled into the comments field, this seems to have slipped past me; sorry about that! I’m going to work on a fix today, and hopefully we can get it released soon.

Sorry about the delay in responding, folks. Bill was without power for a bit and that left us a little understaffed compared to usual. We’re all taking a hand in responding to posts, now, so hopefully that will get support back to speedy & helpful :slight_smile:

Thanks very much,