Clip to DT hangs the FF and other apps

I’m using FF 3.6.15 and just downloaded the latest version of DT. The clip to option works fine in Safari but not in FF. When the blackbox comes up, I choose web archive or note. A new tab on the browser opens then I loose all control of the browser and have to quit. I can’t gain access to my other open applications either.

It does not appear that anyone else is having this issue so I was wondering if there was a setting I need to look at.


Is DEVONthink running when you do this? If not, can you try launching it first and trying again? If it was running, could you try quitting and relaunching it first, please? Thanks!

Hi Rob,

I tried with DT running and without it running, no luck. I also tried unintalling the addon then reinstall. Let me know if there is anything else I should try.


Only thing I can think of is to try it with the latest version of the extension (available on our website at the usual place) and Firefox 4. Let me know how it goes!