CloudKit encryption key mismatch

I have run into some trouble with an invalid encryption key on my iOS devices when trying to set up DEVONthink sync.

Initially I thought that I might have misremembered my password, or had a typing error, so I moved into an uniquely generated password instead, stored in a password manager.

I have changed the encryption keys on both ends (mac & ios) to match the new password, and, after agreeing to DEVONthink prompt to recreate the backup from scratch… it still says that the encryption key on the iOS is invalid :frowning:

Am I missing anything in the process? e.g. perhaps I should try to reinstall the DTTG on ios or manually remove all DEVONthink database sync data from my icloud? Or perhaps there is an implicit password length limit on iOS device? (the password that’s chosen is ~37 chars long).

Why do you not try a shorter one, 15 to 20 chars is sufficient?

1 Like

Careful: sync is not backup!

How are you entering the password? So are you typing it, using copy and paste, using copy and Paste across devices…?

1 Like

longer password == less susceptible for brute force attacks. Of course if there are technical limitations, then it’s a different story (however, in such cases the UI typically notifies about password/key requirements ).

edit: I tried setting it again, this time with 20 chars - still same message on my DTTG after ensuring they match on both sides.

edit2: after clearing the sync databases in icloud… it seems to have worked! thanks for the suggestion, I guess I can live with 20 chars here :slight_smile:

@Blanc, good question! I’m using a password manager (Bitwarden) - the password itself was generated within the app, and then pasted straight from the application. The same setup works for all my other apps, even with longer passwords.

I use 64 characters (generated in 1Password) for sync encryption without issues.


@chrk thanks for confirmation! I must’ve done something else wrong, maybe not clearing the sync properly in the first place…

1 Like