Cloudkit synch does not work for one of the databases

I have several databases setup via Cloudkit synch. On my mac everything works fine, but on the mobile devices not.
For one of the databases it does not download most of the files. The preview is shown but when I click on download a grayish pop up comes where he states download but then nothing happens. If I create a file on the mobile device, it is correctly snyched to the mac.
I tried the following already:

  • switch off synch on the mobile device, delete databases, enter icloud (cloudkit) synch information again. Then it started to download the databases, but again, only the previews show correctly, but the files aren’t downloaded although I clicked the button it should download all (in the setup of the synch).
  • thoroughly checking the database (both on mac and mobile device) went fine through but without any further positive effect
  • repairing (both on mac and mobile device) went fine through but without any further positive effect

Lots of people here report issues with Apple’s CloudKit sync service. That being said works for some. Bottom line it could be unreliable and it seems to be so for you.

I suggest you try Bonjour, and if you really need internet syncing, then try Dropbox which works well for me and others.

Apple provides no tools or techniques to debug their service. Other services just seem to work.

1 Like

Well, it worked in the past, but now it stopped. So it is quite annoying to setup again a new synch solution which will probably even cost money as the free space for dropbox is quite limited.

The value of something free that doesn’t work reliably seems to be fairly limited to me.

In case someone is interested, here’s an in-depth look at the changes Apple introduced to its iCloud Drive in Sonoma.

Not directly related to CloudKit sync, probably.

Well, iCloud is not free when the stored amount is larger than the free part (as for Dropbox and other suppliers), so your comment is a bit pointless. But thanks for the link.

1 Like

I know others have made this point in other threads but it deserves to be made here, too. iCloud syncing works very reliably for many other 3rd party apps (Craft, obsidian, mindnode, drafts, OmniFocus). So placing the blame solely on iCloud doesn’t make sense. If the problems were solely due to iCloud then they would affect every app that syncs with it — not just DevonThink.

1 Like

iCloud seems to work for some. And not for others. Personally, I see files in Cloud Drive arrive between 0 and 20 minutes after I saved them there. Not even Apple’s Photos are always reliably synced for me.

As to different apps: afaik, most, if not all sync files only. Not files and separate metadata, possibly in different locations. DT’s sync is a tad more demanding, perhaps.

No, that is not true.

  1. CloudKit is not iCloud Drive. An app that merely stores it data in an iCloud Drive folder is not doing the same thing.
  2. The underlying technologies aren’t necessarily the same. File-based applications are very different than CoreData / SQL-backed data.

Just for the record. I was able to fix the issue as follows:

  1. I used the intelligent group that shows which files have not been downloaded yet to identify the issues.
  2. Then I checked whether the files were available:
  • if they were on none of my devices available then I (sadly) deleted them
  • If they were present then I created a new database and copied all files form the old one over to the new one, removed the old one from synch, and renamed the new one to the old name.

Et voilà, the files synch perfectly again.


Glad to hear you have it back up and running :slight_smile: