Command + option + F issue on external keyboard

Hey there,
I’m having the extact same issue described here using an external keyboard (logitech mx keys)

with the global database search shortcut (command + option + F)

I’ve tried to edit prefereces as told in that post but for me isn’t working. At the beginning I thought this was because of the external keyboard is managed through the unify wifi dongle and not through bluetooth.But I’m having the same issue on the macbook main keyboard: command + option + F works only with FN key.
On the external keyboard, even pressing FN key won’t make the shortcut work.

The strange thing is that at the beginning the shortcut was working on the external keyboard.

Welcome @vixxovs

I would see if you have the command assigned to another operation.

PS: Logitech is well known for having apps that overtake hotkeys. I’d start there.


Let me say: thanks. DT is pretty amazing, It’ss the app I always looked for, the features and the app design are something like you’ve read my mind.

Pointing to the issue with the shortcut:
I’ve checked in macOS’ System Preferences if the shortcut is assigned to something else but It isn’t.
I’ve searched all the Logi apps for shortcuts like that but I’ve found nothing about.

The strange thing is that the issue involve also the MacBook keyboard, where I can solve that by using FN button in addition to the shortcut (not so convenient) while on the external keyboard, even if at the beginning the shortcut worked, there is no way to evocate that.

In the keyboard visor all the keys seem to work correctly.

Logitech even assigned keybodes invisibly. There was a longish thread here about one or two years ago. In it, sinecure mentioned tools that permit to find all shortcuts and the APIs using them. Maybe searching for Logitech in the forum unveils it.


Issue solved here’s how:

Thanks @chrillek you addressed me to the solution
I’ve searched for the post and I’ve found this one

where they suggest to use “shortcutdetective” so I discovered that the app Rectangle (an app used to menage windows rapidly) was using that shortcut, remapped It and now everything works.

Thanks you all for the support!

1 Like

Excellent and glad to hear it! :slight_smile:

1 Like