Component locations after installation

The installation directions are unclear. When I open the disk image the directions imply that all i have to do is drag the application symbol to my applications folder. What is to be the disposition of the other components in the disk image? (i.e. scripts and macros)

MAc OSX 10.3.7

First, in Finder create a new folder in Applications and name it, for example, DEVONthink PE folder.

Then drag all the contents of the DT image directory into that folder.

Note: There are (rather minimal) instructions inside the Scripts & Macros folder on how to use them. It can also be useful to look at the Version History file, as there are changes not covered in the user manual.

I simply drag-installed as normal w Mac OSX Jaguar 10.3.7. I used DEVONthink pretty successfullly from my iBook, getting used to it, for a couple of days. Since I am wirelessly networked to my remote desktop computer I read about using the same Dt database on another machine, followed the instructions & then launched Dt on the desktop machine. It launched but behaved wierdly. I subsequently discovered the desktop had v. 1.8 on it. So I launched the updater but something interrupted the install and an alert presented itself saying that some incomprehensible filename or something didn’t install or had done some cryptic thing. I clicked through it (all I could do!). Now Dt will only launch with totally greyed out menus on both machines. I have deleted prefs, tossed all databases (REGRETFULLY!) and all else I could find (there is no ‘installation log’ that I can find…). So I thought, now I need to uninstall Dt but there is NO SUCH INFORMATION, no deinstall or uninstall instruction anywhere.

I wanted to try this app instead of Stickybrain, but this is terrible. I have lost several hours of trying to see if the blank menus were something I should know about, learn how to use, or if they are a glitch. Info in ‘troubleshooting’ does not address this.

I have no idea what to do…


Bill Marston, Phila

So the original database is still on your iBook. Try it and check whether this works still well.

Now are some ideas that might help on your desktop, since the problem seems to stem from using an inappropriate version with your data: Delete your DT folder in the Application Support folder in your Library. Install DT from scratch (the newest version :wink: ) and copy your database folder from the iBook to the place it belongs on the desktop. It should work now.

You can try as long as you keep your db on the ibook untouched, I am using DTPro since several months now and am not 100 sure where DT PE puts all folders, but it seems to be OK this way.


Bill Marston wrote:

The database is stored in Users > usernmame > Library> Application Support>DEVONthink. Delete the DEVONthink folder.

The preferences file (and a registration file, if registered) is stored in Users > username > Library > Preferences > com.DEVON…etc. Delete the DT preferences files.

Delete the DT folder in the Applications folder. If any scripts, e.g. from the Scripts & Macros folder, were installed in the scripts folder of another application, remove them from where you placed them. That’s it. (But it would be a shame to give up on DEVONthink.)

So far, so good. DT was working for you.

Looks like that’s where things went wrong. There are lots of potentials for disaster here. (I don’t know how you shared the database between two machines. Personally, I would only do this by transferring a copy of the database back and forth.)

One would be trying to open the same database from two machines at the same time.

You mentioned that the desktop machine had an older copy of DT on it. Had the trial period elapsed? That could have shut things down. (I’m guessing this was involved. The newer copy on your laptop could have become flagged as expired. Otherwise, I don’t know how both copies of DT became nonfunctional.)

It’s possible that your database that was originally created on the laptop was still OK.

StickyBrain is a neat little app. I’ve used it. But DEVONthink is enormously more powerful, depending on what you need to do.

Thanks to Bill and to Maria!

The trouble is NOT in the database, because each new “install” I have made on either machine, independently and unconnected to the other machine, produces the same result: an “empty” database in the ~Library> Application Support>DEVONthink folder. Said database consists of 10 databases, all identically sized at 4K. A QUIT and RELAUNCH produces the same greyed-out menus, and nothing - not even dragging a test file onto the Dt icon - changes that database, even if I QUIT Dt again and look at those files in the Finder.

DEVONthink just won’t work despite dragging everything Bill DeVille mentions to the Trash. It makes me feel like I’ve left some little file hiding someplace that refuses to acknowledge the database etc.

Y’know what? I’ll try a QUIT then a Repair Permissions… on one machine at a time.

Bill Marston

Bill Marston:

Just for the heck of it, try this: File > New Browser. Then try Content > New > Rich Text. Type something.

By any chance, is DT working now? (Maybe there was no browser window open.)

There is no way to create a new browser (greyed out = non-functional). Import…? Nope = non-functional. Link…? Nope = non-functional. Tools…? Nope = non-functional.

Every single action command is greyed out no matter what I do. Only ones active are things like Page Setup; about half of Format > Colors, and the like; View > Sort… but when it comes down to actually having a file or text or data entry upon which to use these limited choices - no way since there are NO RECORDS to act upon.

I am open to any other ideas tomorrow or Tuesday… . going to sleep now (2am local time).

Bill not-DeVille,

your experience sounds bad. I would contact the support right before breakfast tomorrow morning and if necessary send the db to them, they are very helpful and can only learn from a case like yours. Even if it is not DT’s fault, there should be precautions that other apps or failures affect the database. This cannot be, this must not be.

Best wishes,

Have you tried to contact our support yet? Please contact us so that we can work on the problem.



I received instant support from Eric at DEVONthink! Having found no help in the Dt manual, and having encountered the old-new version updater glitch, I assumed I had seriously broken the Dt software… but after listening carefully to me Eric explained that the 150 hours of “usage” are actully the number of hours the app is running, even if the computer is asleep or is being operated by another login under MacOSX “fast user switching”.

He gave me brief expert advice and he took note of my user experience (I saw only one reminder of the time limitation early in my sampling of Dt. I recommended that a repeated reminder be incorporated or a text in the menu saying “150 hour limited use” - I think it need not include a dynamic time counter).

I received nothing beyond this conversation with him, and I neither asked for nor expected any special consideration. This behavior of such high integrity caused me to have the utmost confidence in the software AND in the developers who created it.

Thank you, DEVONthink!

I suspect that the symptom of grayed out menus indicates that DT or DA is being launched from an application location outside the Applications folder.

DEVONthink and DEVONagent are downloaded as compressed DMG files, and the DMG file is opened to display a new directory in the Finder. I’ve found that if one tries to drag this directory and drop it into the Applications folder, it looks like a a new folder has been copied into the Applications folder and that this new folder contains copies of the DT or DA application, together with other files such as version history, etc. But that’s not really the case. Instead, an alias of the directory has been copied into the Applications folder, and the actual files still remain in the DT or DA Finder directory that resulted from opening the DMG. Bummer!

That’s why I recommend manual creation of a new DT or DA folder inside the Applications folder, then dragging and dropping the contents of the DMG-opened directory into that folder. That removes any question as to whether the application is properly located inside the Applications folder.

No, he simply hadn’t paid 8) I sent him a 30 days license for his evaluation and now everything should work again.