Contextual menu interferring with hovering information box

The information box when hovering over a document is undoubtly very useful but gets into the way when the contextual menu is invoked. I would rather prefer that the information box vanishes immediately when the contextual menu appears.



DTPO 2.8.6, OS 10.10.4

I don’t doubt the image, but how are you invoking the contextual menu? I’m not able to reproduce, so I must be clicking something wrong. Over here, the tooltip info vanishes as soon as I control-click or right-click the document name.

Interesting. In my case, the tooltip info stays, no matter if I control-click or right-click. It also does not depend on the view (three-pane, list etc.) and even happens in the “See also”-window. At the moment, I am working on my Macbook Pro, but if I remember correctly, I encounter the same behaviour on both iMacs at home and at work.
I have installed the most recent versions of DTPO and Mac OS, so it perhaps has something to do with the German localization (which, however, would be funny considering the fact that a substantial part of the DT-staff is German-speaking)?



It’s not an issue of the localization, I can’t reproduce this either.

After being back from holiday, I have now tried again at my imac at home, and here it is the same issue, easily reproduced. I could provide more screenshots, if this would be of any help to track down the cause.

Just for clarity – you’re saying you’re seeing this now on a different machine?

Is it with an instance of the same database?

If you were to quit DEVONthink – move the current preference plist to the desktop – reboot and reopen DEVONthink and the database – does the problem recur?

If you toggle off the apps in System Preferences > Privacy > Accessibility does that change anything?

Do you have any special keyboard and/or mouse or display settings in System Preferences > Accessibility?

I wouldn’t flip all these switches at once – but they are things to explore. Some Accessibility settings can cause visual elements to stick.

I had this problem over several versions of DTPO. Drove me nuts. I followed the instructions in this article to set the delay for tooltips’ appearance in DTPO to 30 seconds. I don’t find DTPO’s tooltips all that useful, so this works for me.

Thanks for your suggestios, korm. I tried them, but none seem to solve the problem.

I am glad I am not the only one. And many thanks for your tip which indeed provides a very useful workaround! I have now set the delay to 10 seconds.