Convert 1.x Database to 2.0


I got a copy for DevonThink via Macheist. I had been wanting to try it but never got around to it. After using it for a few days I’m in love with it. It’s everything and more that I miss about MS Onenote from my PC days. Anyway I moved a lot of information into the 1.x version of the database that I had stored into Text Files and other folders. So now I have a nice database will all my necessary notes and other things in it.

Now I decided to try version 2. Which seems a lot nicer. But I can’t find a way to move my 1.x database into 2.0. Is that possible. I sure hope so otherwise I think I might just stay with version 1.x and not upgrade.


DEVONthink Personal 2 should offer the option to convert the old database after launching it for the first time. I’ve just checked this and it’s working fine over here.

After deleting the preferences (com.devon-technologies.think2.plist) version 2 should ask you again.

Two questions then.

I have the license to the personal version now but I like it so much that I think I’m going to upgrade to the Pro version. I downloaded the beta 2.0 Pro version. Should it still convert or should I download the personal version to convert the database to version 2.0

Second is that I keep all my document files on an encrypted disk image made possible by a product called Knox. Since the database files are not in their standard position is that an issue.


Install & run DT Personal 2.0 first, then DT Pro 2.0.

I don’t think that this is going to cause problems, there’s no “standard position” for DT Pro’s databases.

I downloaded DevonThink Personal Beta 2 and it did infact convert my database. So now I have that work ok. But I still don’t see any way to get it into the beta of Pro Version 2.0. It doesn’t look like they use the same format. Anyways

I got it. I just needed to rename the folder. Thanks for the help.

Related: I’m having trouble having DT Personal 2.0 prompt me to convert my previous DT Personal 1.x database.

I have deleted com.devon-technologies.think2.plist, but still to no avail.

Any thoughts?

Where’s your v1.x database located? The default location should be ~/Library/Application Support/DEVONthink.

Yes, it is there.

I think I got it: I had to delete the DT2 folders/files (under “Application Support”) and the .plist file (under “Preferences”)–it seems to be working now.

I’m having a problem that is a combination of this thread (converting my 1.x database) and not having a database open when I first start DT2.0 (similar to this thread: viewtopic.php?f=3&t=7785)

This is what is happening:

I install 2.0.
It asks me if I want to convert my 1.x database.

After I click “OK”, DT2.0 is running but no windows are open and none of the database menu options are available (because no database is open).

If I quit DT2.0 and restart it, everything is working as normal but the default database (with nothing in it) is open. Not a converted version of my old database.

I tried deleting the DT2.0 folders under Application Support and deleted the DT2.0 .plist file.

On restarting DT2.0 it re-asks me if I want to convert my 1.x database and the same issue occurs.

Any thoughts?

Has been anything logged to the system console? (see /Applications/Utilities/

Has anyone been able to convert a 1.X Personal database to a 2.0 Pro database?

I’m having problems trying to convert a 1.x Personal database to a 2.0 Pro database. My 1.x personal database is over 1GB in size, with documents that have been collected over a five-year span of time. With the increased capabilities of the 2.0 Pro version, I decided to upgrade, but now I can’t view any data at all via the 2.0 Pro interface.

I renamed the old database folder with the .dtBase2 extension and the icon image changed to indicate that it is now a 2.0 version. Then I tried to open the database in Pro 2.0, but nothing is visible.

I have tried installing Pro 2.0 twice, once yesterday when the old personal 1.x version was still on my computer, and again today after I had taken the rather extreme step of removing all DevonThink programs, library folders, application support folders, preference files, caches, etc. completely from my system. I didn’t even keep the folder that had my old data in it since I had a Time Machine backup copy that I was planning to use in order to start fresh. But still no items from the previous database are visible, even though the left panel in Pro 2.0 indicates that it’s an open database.

I’m perplexed by this and am wondering if I tried to upgrade too soon, while 2.0 is still a public beta.

This does not work of course, the databases are completely different. But you could add .dtBase and let DT Pro 2.0 convert it to .dtBase2.

It’s been a while since I’ve had the chance to try use the new DevonThink 2.0 again.

Please see my post 3 posts up to see the trouble I’ve had converting my 1.0 database.

You wrote in response : “Has been anything logged to the system console? (see /Applications/Utilities/”

The answer is no…Installing DT2 and initiating the db convert does not log anything new in the system console.

After agree to convert, the progress bar goes across the screen, the window disappears, and…nothing. Only the DT menu is running at the top of the screen. There is no db open. I have to quit and then start DT again to have a db open (but it is not my 1.0) one.

I’ve tried this multiple times (after clearing the DT2 folders and .plist files)

Assuming that your DT Personal 1.x database is in good working order, here’s a way to move the data to DT Pro 2 or DT Pro Office 2:

  1. Quit DT Personal 1.x.

  2. In the Finder, copy the database folder, named DEVONthink, from its location at /Home/Library/Application Support/ to your Documents folder.

  3. Now, in the Documents folder, select the folder named DEVONthink and Control-click (right click) on it and choose the contextual menu option, Get Info.

  4. In the Info panel, rename the folder by adding the suffix “.dtBase” (without quotes, but case is important). Close the Info panel. The folder has now become a DT Pro 1.x database.

  5. Launch DT Pro/Office 2 and choose File > Open Database. Select and open the newly converted database. A new DT Pro/Office 2 database will be created. Examine it to see if it appears to have the organization and content of your DT Personal 1.x database. If so, run Tools > Verify & Repair to check for possible errors. If there were errors, run Verify & Repair again to see if they can be corrected.

If there were serious and uncorrectable problems with the new version 2 database, the original Personal database likely had problems. Quit DT Pro/Office 2 and launch DT Personal 1.x. Run Tools > Verify & Repair. If there are errors, run it again to try to correct them. If the errors cannot be fixed, try Tools > Restore Backup and choose the most recent internal Backup folder. After restoring to the state of the database as of the time that backup was done, run Tools > Verify & Repair again. If errors persist, try Restore Backup again, moving to the next most recent Backup folder, etc. Note that you will have lost content added to the database after the time that backup was made. If you can get a working, error-free database, go to step 1 above and repeat the procedure to end up with a DT Pro/Office 2 database.

If none of the internal backups can restore a sound database, choose Tools > Restore Database once more, and this time choose the most recent internal Backup folder. This will restore the state of the database to the original starting point. Now try Tools > Rebuild Database. When the rebuild is complete, examine Window > Log to see if files that failed to make the rebuild are listed. If so, save the Log as a text file, for possible use in locating the named files for import into the DT Pro/Office 2 database. Finally, go to step 1 above to convert the rebuilt database.

That covers about as many contingencies as I can think of at the moment. :slight_smile: Fingers crossed, the first 5-step procedure should do the job.

When you have converted your data to the DT Pro/Office 2 database, I recommend occasional use of Scripts > Export > Backup Archive (not available in DT Personal). Whenever I’ve been investing time and effort in significant modifications of a database, at break time I may run Backup Archive. When I return from break the database has been verified, optimized and has current internal and external backups. The archive file is the smallest possible compressed and dated complete backup of your database. It’s a good idea to store it on an external medium as insurance against a hard drive crash. If the data is important to you, you may want to store the archive file offsite, as that will cover you from theft of your computer equipment, a house fire, etc. Although fortunately relatively rare, Bad Things Do Happen to People. Backups can be insurance against some of those Bad Things.

@ mscote:

One more contingency. If you are trying to convert your DT Personal 1.x database to DT Personal 2, and the procedure for automatic conversion isn’t working for whatever reason, try this:

  1. In DT Personal 1.x run Tools > Verify & Repair to ensure that the database is in good order. If there are unrepairable errors try a Restore Backup or Rebuild Database procedure to try to get a sound working database.

  2. In DT Personal 1.x, choose File > Export > Files & Folders and select ALL the content of the database for export. Create a new Finder folder to hold the exported content. When the Export is complete, examine the Log and save any list of files that failed to make the export, for future reference. Quit DT Personal 1.x.

  3. Launch DT Personal 2 (the current version is DT Personal 2.0 beta 5). This will create a new, empty database (assuming the auto conversion isn’t triggered again, or fails again). Choose File > Import > Files & Folders and select for import ALL the content of that folder holding the previously exported material. When the import is finished, examine the Log and save any list of files that failed to be imported, for future reference.

That last option worked…

I had no problems with my 1.0 db, it just wasn’t converting with the upgrading prompt.

Exporting all my files and re-importing in 2.0 PE did the job, and kept all of my hierarchy. Just what I needed. Now I can get back to work on my Genealogy project. Thanks!