Convert Wiki-Links to Item Links Not Working Properly


I rarely post to the message board because most of the questions are answered by someone else, but I am struggling with the newest update concerning the conversion of Wiki-Links to Item Links.

I like to convert my Wiki-Links to markdown links due to it’s stability inside and outside of Devonthink. And up until the recent update, I was able to individually select a wiki-link and right click to convert it to an item link. I can’t remember if this was built into Devonthink or a plugin. But since the update, this option no longer exist, and that would be fine except I am running into more serious issues: mainly, deleting my Wiki-Links and miss-associating other Wiki-Links. This doesn’t always happen, but it 8 times out of 10, I lose Wiki-Links. Also, there is an issue where it requires me to leave the note and come back before the “Convert Wiki-Link to Item Link” option will work.

I’m use to finding work-arounds to problems, and I am currently working on to this problem too, but I thought I would post to the forums about this issue. Systematically speaking, I would ask

  1. Am I doing something wrong? (Since nobody has posted about his issue I can assume it might be something on my end.)
  2. Is this a bug?
  3. Suggestions to fix this issue?
  4. Is there a way to pick and choose which Wiki-Links get converted to Item Links?

I don’t really have much other details to post. Everything was working fairly normal, ( I say fairly normal because before the update, I would sometimes have to try convert a Wiki-Link multiple times before it converted) until the latest update - which is a great update by-the-way.

Thanks for your time.

Welcome @shicklepd

Tools > Item Links > Convert WikiLinks to Item Links converts all WikiLinks in a document.

We have no other reports of WikiLinks being lost.
Is this something reproducible?

Hi BlueFrog,

Yes, this is something that I can reproduce very frequently.

Hold the Option key and choose Help > Report bug to start a support ticket. Please attach a screencast of the behavior. Thanks!

Will do. Thanks.

What kind of documents do you use and which WikiLinks settings (see preferences)? There’s a known issue in case of rich text and WikiLinks based on names & aliases or MashedWords.

I am unable to get this option to do anything to either [foo](/baz) or [[/bar]] links.

I feel like I’m not doing it right?

I use markdown for everything. And my settings are both “names and aliases” and “square brackets”.

Names and aliases (in addition to square brackets) lets the names and aliases it finds be converted, but not the stuff actually in square brackets?

Does this stuff already exist, meaning that the links have a valid destination?

Both valid and invalid destinations. But it turns out, with indexing, that relative paths work, but absolute paths are not (chroot-like) constrained to the bounds of the wiki directory-hierarchy, so that absolute paths that worked in the wiki, don’t work here.

An example would be useful (and in case of Markdown even better the source), thanks.

[edit] The name and aliases hits were changed to the x-devonthink-link wikilinks, but existing wiki-links were left alone. Turns out that, with indexing done, this is just fine.

The wiki is gitit, which does the web-server style chroot-jail of the directory hierarchy, so that


works because the “studies” directory is at the root of the wiki’s directory hierarchy, not the host system’s.

These two:

[escape route 1](/Users/wagle)


[escape route 2](../../../..)

both escape into the host system’s file system (and notably from that of the devonthink database).

A screenshot of Preferences > WikiLinks would be useful too. Because DEVONthink doesn’t support Wiki links using a path.

Paths worked for me once I indexed the directory hierarchy and enabled wikilinks in preferences.

This is essential for me. My (personal) wiki works only in waterfox (the classic version goes away in maybe a year), but not firefox. Porting it to DEVONthink is the solution.

Would be useful to know the exact options, thanks! As DEVONthink requires double square brackets for WikiLinks, this…

[escape route 2](../../../..)

…seems to be just a relative ordinary Markdown link.

[escape route 2](../../../..)

can go off the top of the database into, say, my home directory.

Is there a way to still accomplish this in the current version? I only want to change those wikilinks that point to pdf attachments and not all.