Copy/Paste not working except the top level

I’ve found a bug in DEVONthink Pro beta. I use two methods for copying web pages. I will either use the print dialog to Save to DEVONthink, or I will select the text I want, then copy it and paste it to a category/group by using the dock icon menu. The latter gives me text I can work with, and this is while I occasionally prefer that method. Both methods worked just fine in the Personal edition, but in the Pro beta, I cannot paste to a category/group below the top level. For example, I found an interesting Mac tip on one web site. I selected the text with cmd-A and copied it. I can paste to the category “Mac Stuff,” but within that is a category “Mac Tips,” and copying there does nothing. Saving to DEVONthink using the print dialog still works.

Reiterating after testing here, in DT Pro 1.0p1 the destination for “New With Clipboard” from the Dock seems limited to creating items in Top Group or a first-level subgroup.

I just tested the Dock approach for dragging selected text and was able to place the material in a subgroup that was 4 levels down.

But I prefer a different approach, anyway, because it’s quicker and the group icons are easier to hit.

In DT Pro preferences, make certain that the option to hide the Groups panel when it is inactive is not checked.

Then select Tools > Show Group. The Group panel will appear. I resize it just wide enough so that I can read all my group names, then drag it to the right side of my screen. It’s now a floating panel that will be present in all applications, not just DT Pro.

Because I don’t want to see it all the time, I click on the yellow Minimize button and it drops out of sight onto the Dock.

Now I can select text and/or images within any application. Next, drop down to the Dock and click on the Group panel, which pops back into view. Drag the selected material onto a group, which will unfold to show subgroups, and drop the selected material in your desired location.

I find this quicker and more precise than dragging to the Dock icon, waiting for it to open, then navigating to a group to save the clipped material.

Try it. You may like it (or not). :slight_smile:

My experience is the same as raycon and sjk. Top level only. I do like the groups trick to Bill, but I wish everything worked. I hope you’re keeping a list for our vacationing programmers! LOL.

For what it’s worth, “new with clipboard” is working fine for me, at least four levels down, both from the dock and within the app itself. Maybe we have something different in our preferences. Don’t know if it’s relevant, but my Mac OS version is 10.3.9.

But I’m a keyboard person, so when clipping from apps that support Services I usually just use command-shift-) and assign groups later.

I’m using Tiger 10.4.1. I wonder if that could be the difference? How about you racon and sjk?


10.4.1 here. Pretty generic, e.g. no hacks. I noticed that when it doesn’t work there’s a console message like:

2005-06-21 12:09:01.642 DEVONthink Pro[10121] *** -[NSMenu newWithClipboardFromDockMenu:]: selector not recognized [self = 0xb035c10]

I’m getting something even weirder. When I attempt to select all using the keyboard nothing happens. Also when I paste the type is white on white background.

Dragging is equally ineffective.

This is in a brand new database.