Copying tags from Mavericks to DevonThink

I have read about tagging items in Mavericks and then being able to import those documents into DTPO with the tags. However, whenever I try it, the tags are not imported. Is it possible & how do you do it please?


This must be national tag day :laughing: – in the other thread, the reader cannot get rid of tags, and in your thread you cannot add them.

Seriously – sometimes adding tags in Mavericks doesn’t take immediately. There is a delay. But, generally if you add tags to a document in Finder > Get Info or by using Tags in the Finder sidebar, and then drag that document into DEVONthink you should be able to see the tags. You are saying that doesn’t work for you – ?

No the tags are not imported at all, have just tried what you suggested

I see the same behaviour - if the Mavericks tag was converted from a pre-Mavericks label, then it is not imported into Devonthink. Newly-created Mavericks tags that were not labels in a previous life do seem to be imported, however.

@BillW are you experiencing what @khw described, or do you have the trouble with all Mavericks tags?

(I don’t see this over here, but my testing is limited.)

I don’t get any tags at all coming across

I still can’t get tags to come across. How do others succeed?

Have you installed 2.7.5 (released today 20140417)? It addressed some tagging issues.

Yes, but without success, I’m afraid. You don’t need a version from the app store to do this do you?

No. Is there a chance you could post a screencap of a Finder window showing the Tags on a file and a DEVONthink window with the file imported and a view showing the Tags bar or a Tags column?

Here you go

DevonThink inbox.tiff (364 KB)
Finder window.tiff (239 KB)

Is it just the color label you’re missing, not an actual Tag?

No, if you look there is no tag. The colour label is associated with the tag CBC

Instead of using a named color label, add a text Tag and try importing that.

The latest release hasn’t solved my problem either. Mavericks tags that were pre-mavericks labels aren’t imported. New tags that have been created under Mavericks are imported. I attach a screen shot showing a simple test dataset with two files that were both indexed and imported. The screen shot shows the Finder information for the two files. The ‘markdown’ tag is a new one I created after upgrading to Mavericks. The ‘important tag’ was a red label in my pre-Mavericks OS. The DT tag column shows that only the ‘markdown’ tag is brought into DT.

hmmm … I experimented with importing files with a brand-new database made by 2.7.5 – the “real tag” imports but the “legacy color label” does not. Seems like the experience reported above.

The tags are there – if I select the file and “Show in Finder” from DEVONthink’s contextual menu, I can look at Get Info and see the tags. They just do not appear in DEVONthink’s UI.

@khw and @BillW – if you do what I did – use Show in Finder to look at the documents in your database with Finder, do you see the tags in Finder’s Get Info?

Yes the tags are there in the Show in Finder view, but don’t appear in DTPO as I would expect. A comment entered via the documents Get Info option shows up after import.
I had hoped it might be easy to tag documents before import, but this seems a forlorn hope.


Yes, the image I attached had the two Get Info panels from Finder and both show the tags, but only the non-legacy colour label one appears in DT

UPDATE: re my post three above this one - the ‘markdown’ tag, the one that appears in DT after importing/indexing is uncoloured. I have now selected in Finder one of the Maverick colours for the ‘markdown’ tag - and the tag disappears from DT after updating indexed items! And likewise there is no sign of the coloured tag after importing the file into DT again. So the problem is not with legacy labels that have become tags, it seems to be with tags that have been coloured with the Maverick preset colours.

DEVONthink has never imported label indices from files, regardless if the name has been assigned in the Finder.

The kMDItemFSLabel is set but is the name is duplicated to kMDItemUserTags (Mavericks Tags). So the problem isn’t that Mavericks Tags aren’t being imported. Non-label index Tags are indeed imported. However, there is a small issue in that the Mavericks Tags realting to the label index should be imported too.

Thanks for the explanation. I hope this can be corrected. What you call a small issue is actually a big issue for me because most of my tags are coloured in Finder.