Craft Doc Links Not Opening in DevonThink

I draft a document in Craft, then “transfer” the document to DT. The document in DT shows the link to the Craft doc (which links to the document if you put it in safari), but the link does not work within DT.

I’ve tried clicking on it, it shows the little hand icon that indicates it’s a link, but when I click on it nothing happens. I highlight the link, right-click, choose “open link” and nothing happens.

Is there a setting or something I’m missing here? I went into preferences/General/Interface and selected “Click on link opens them externally” but it made no difference.

Which means “what”, exactly? Do you import it into DT? Do you index it from DT? Using a word in quotes is confusing, at least to me. Or are you trying to be ironic here?

Assuming you’ve added a bookmark, select the file, then choose Data > Launch URL or press Control-Command-U.

“Transfer” is not irony; it is the export method as it’s called by Craft. It also has an “Export” function.

And yes, it’s imported into DT

“Launch URL” is dimmed out so can’t be selected; Control-Command-U has no effect.

I believe it’s a URL or “deep link” from Craft. Here’s a sample: Link to Original Document. craftdocs://open?blockId=890C7B7B-7BFB-4600-81E2-D04F397FBEEA&spaceId=f571190e-e0d6-4f5f-11dd-67983a566d7e

If I paste that link in Safari, it opens the doc in Craft

I don’t quite follow. If the document is imported into DT, where does this URL come from? You should have a document that you can open in Craft doc with a double click from DT. Since you apparently have a bookmark… I don’t know.

But according to their documentation, you can export (their word) to DT. What does that result in?

What type of file is it in DEVONthink?

It’s a Markdown file.

The link is a deep link for markdown. Since it works in Safari, is it possible that DT doesn’t support links to Craft?

I’m “transferring” a Craft document to DevonThink. When the document shows up in DevonThink, it’s a Markdown document with the link back to the original document in Craft. It looks like this:

Unfortunately, the link does not function. I can highlight it and select “open link” and nothing happens. I get the little hand icon indicating a link, but when I click on it or double-click, I get nothing.

If I paste the link into Safari, it correctly opens the document in Craft.

See screenshots below to help you understand what’s going on. Craft has two options to export a file; one is called “export as” and opens a finder type window, the other is called “transfer” and sends a stripped down copy of the file and a link back to the Craft doc to whatever app you choose from the list.

The link to Craft works perfectly in DTTG, but not the DevonThink app on my Mac. The link appears as “Link to Orginal Document” in blue in DTTG.

Perhaps this indicates an issue with the DevonThink 3.8.5 app?

And the app is installed on the same machine as DT is?

Note: We don’t run Craft here.

I just installed it for this test and will see if I see the same behavior.


I have confirmed the behavior here. It appears to be isolated to DEVONthink as the URL works in MultiMarkdown Composer (i.e., it’s not a MMD issue).

@cgrunenberg will have to assess this when he returns from holiday.

Thanks for testing it.

I have heard from another Craft user who is having the same issue. He indicates that in the past the links worked properly in DT3, but recently they stopped working.

And as I indicated, the links work properly in DTTG. That seems to confirm that it’s likely a DV3 issue. Maybe an unintentional update issue?

Will await cgrunenberg’s return from holiday.

1 Like

Did you edit or preview the Markdown file when clicking the link? Does it work in e.g. rich text documents?

Hi, this may not clarify things but several months ago I noticed that the ‘transfer’ function from Craft to DevonThink Pro wasn’t working. I liaised with Craft’s ‘helpline’ and after a while was able to work out that the ‘transferred’ text copied over to DevonThink Pro ended at the first ‘semi-colon [;]’. Weird but true. I passed this on to them and they said they would address it in the next update. I’ve just tried to ‘transfer’ several Craft pages and they also didn’t fully ‘transfer’ over (one stopped at a ; but others stopped without a ;). So it’s still a bit random. It’s worth letting Craft know that it’s still not working.