Crash: DEVONthink 3.7 hangs with md files on one machine


Today I updated all if my machines to DT 3.7 (2x Big Sur, 1 x Catalina). Really liking the new Markdown WYSIWYG Option. But on one machine (Big Sur) DT hangs with some markdown files. If I activate the WYSIWYG option in settings, select a specific file and change from preview to source mode DT hangs, I get the beach ball of death and DT can only be terminated. This happens with more than one md file. On the other two machines everything works as it should, no beach ball of death…

What I did until now:

  • reinstalling DT
  • checking and repairing the database
  • optimizing the database
  • rebuilding the database
  • opening a new md file and copying the content over

Nothing solved my problem. But it only happens on one machine… No CSS used, by the way.

If I try to change from preview to source mode both icons are activated and the system crashes…

Screenshot_2021-04-22 21.05.29_f66ap5

Any idea what to do?

Thanks for your help

DT generally request that crashes should be reported via their support system (select Help and whilst holding the Option-Key select Report Bug ).

1 Like

I have only just downloaded and installed DT 3.7 (running on macOS 11.2.3) and discovered that, when selecting a markdown file and using the toolbar to switch from preview mode to edit mode, DevonThink hangs and has to be force quit. If I then disable the preference for WYSIWYG markdown editing that does not happen so I have for the time being disabled that preference.

Apologies but I need to sleep now so any reply to responses may be a little delayed!


Could you please launch Apple’s Activity Monitor application (see Applications > Utilities), select the frozen DEVONthink 3 in the list of processes, choose the menu item View > Sample Process and send the result to cgrunenberg - at - A copy of one of these documents would be great too. Thanks in advance!

Hello Christian

As suggested by @Blanc I sent contacted support through the Help => Bug Report step. Jim already wrote back that you will need the crash dump. A copy of one of the files was already sent by me in the original message. My Support ID is 296824.

Is it possible for you to look this up in your system? I thought “double” sending it to you again would be not so great because both of you would work on it…

Thank you for looking into it

Yes, I can view the ticket too. Thank you!

I’m seeing this too so have turned off the WYSIWYG. Let me know if you want another sample from Activity Monitor.

Which version of macOS and which plain text font do you use?

If you need more samples just let me know and I’ll do the same.


Samples aren’t necessary anymore, the used macOS version and plain text font would be helpful. Thanks!

macOS 11.2.3. Plain text font Meno Regular 13 (white text on black background, for good measure!).


And is this on an Intel or M1 Mac?

Intel mac—sorry, yet another thing I should remember to mention these days!


My M1 11.2.3 and Lucida Grande crashed. I also tried on an Intel Mac 10.15.7 and Menlo Regular 11 but it doesn’t crash on the same Markdown doc. I also have custom CSS and a script that puts all the text into a custom metadata tag (on the crashing machine).

Crashed or froze?

Sorry, froze - as reported by others. DT hangs for long enough that I force quit. I haven’t tried turning WYSIWYG back on because I have usually have 9 or 10 databases open and don’t like dealing with ‘locked’ dialogues, etc., on restart.

Does deleting the preferences fix this? Just enter defaults delete com.devon-technologies.think3 in the while DEVONthink 3 isn’t running.

Yes, seems ok now. Thanks.
Also, might not be relevant but I happened to open one of the .md docs in BBedit and noticed lots of ‘gremlins’ (showing as upside-down question marks). I’ve no idea how these got in there. The doc originated in DT but has had lots of pasted URLs, etc and editing over time, only in DT and it’s sync’d to mobile.

Maybe the document uses UTF-16 but BBEdit uses the wrong encoding?

Hello Christian

I can confirm that this fixes the problem for me, too.

1 Like