create new word document

Is there a way, within DevonThink Pro, to create a menu item “Create new Word document”.
Right now, there is an option to create new X - which gives some options - I would like to create a new word document from this menu.
Another option would be to create a Macro or Template from within DevonThink that allows me to do this (?)

Thanks for any help

Just select Data >
Open Templates Folder
and add a template Word document to this folder (or a desired subfolder. It will now be available under Data > New from Template.

If you add it to the Toolbar folder, you can quit and relaunch DEVONthink, then add it as a button to the Toolbar by right-clicking the Toolbar and choosing Customize Toolbar.

1 Like

Tried that - but a “word” template does not seem to exist.
When I get to “Install Devonthink extras”, I see some extras, but nothing related to Word.

There is no built-in Word template. You should make a document in Word and add it to the folder as I mentioned.

Ahhh! Now I get it. Thanks - that worked.

You’re welcome.

Allow me to jump on this one: this is exactly what I’m looking to do. I’ve managed to save a blank word file to the Templates directory and clicking New from Template --> “Blank Word Doc” works just fine.

I went and copied the “Blank Word doc.docx” to the Toolbar directory and restarted DevonThink Pro. And voila, I found a new button with a Word icon which I moved to the Toolbar.

When I click on that button, however, Word starts with the document and then tells me: “Read only. To save a copy of this document, click duplicate”

When I hit the Duplicate button, Word comes up with the standard “Save As” dialog which basically would only allow me to save in the Inbox (which isn’t what I’m looking for).

What am I doing wrong?

Thank you!

Not sure.
Office apps have been known to be fiddly with permissions.

Try saving a file from Word directly to the Toolbar folder. Then quit, relaunch, add the toolbar button, and use the template.

I did this and it worked as expected.

Unfortunately, that doesn’t work. If I try that, I get “Word cannot complete the save due to a file permission error.” I’m on 10.15.7, but then you probably are too - do I need to set permissions someplace else?

I get “Word cannot complete the save due to a file permission error.”

Just like I said: permissions issue (sigh)

Do you have anything else in the Toolbar folder?

And what are your permissions set to in the Get Info pane for the folder in the Finder?

No, the folder is empty.
I just gave MS Word “full disk access”, but that doesn’t fix it. Very odd.
I will tinker a bit - I’ll let you know if I find a solution!

Thank you.


What are your permissions set to in the Get Info pane for the folder in the Finder?

And try saving a TextEdit document into the folder and see if the behavior is the same.

I figured it out.

The permissions were not the issue (my account, group Staff, has full control, everyone else has read permissions: 755).

When I tried it with an RTF produced by TextEdit, no error came up when I clicked the button nor when I saved. Because it actually edited the file in the …/Toolbars directory!
So I dragged a link of the file in the …/Templates directory to Toolbars and voila - everything works fine, even with the .docx file!

So the answer is: put the desired file, i.e. the .docx, in the Templates directory and Ctrl-drag it to the Toolbars directory. That creates a link to the Template file and you can then pull the button into the toolbar to create a new file based on the template every time you click it - even in the main Inbox database.

1 Like

I can’t reproduce this over here, both .rtf and .doc templates in ~/Library/Application Support/DEVONthink 3/Templates.noindex/Toolbar work as expected after adding the new items to the toolbar. The template is imported to the current database and editing it externally afterwards does not edit the files in the Toolbar folder.