Database already open message

I’m still pretty new to DT, but it’s clear that it is a very good program!

Problem: I tried to transfer the datafiles from my desktop to my laptop so I could work away from home. But when I try to open DT on the laptop I keep getting a message that says "database already open" (or similar words).

Where did I go wrong? What do I do about getting a successful transfer to the laptop?

Thanks for the assistance.


You’ve probably copied the DEVONthink folder while the application was running (or after DEVONthink crashed?). Just delete the DEVONthink.lock file and things should be fine (but copying DEVONthink databases while the database is in use is really not recommended - the copy might be corrupted!).

Yep, I guess I had DT open on the machine from which I copied the database. Tried it again with the program closed and the transfer went perfectly smoothly.

(By the way, what does the DT.lock file do? I don’t recall reading about it in the manual.)

Many thanks.


Locking prevents multiple DEVONthink instances from accessing one database concurrently as this could/would corrupt the database (e.g. if your database is located on a common server or if you’re the developer and running the latest build and previous builds at the same time ;D)