"database is already in use"

When I tried to run DevonThink Pro Offce (1.5.4) today, it gives me an error message “database is already in use”. Everytime I try to open the database, it gives me the same error message. :frowning: What can I do? Help!


Your database is single-user. That is, it cannot be opened by more than one user, or by more than one DEVONthink application at the same time.

If you also have DT Pro installed in your Applications folder, make certain that it has been quit. We do not recommend having more than one DEVONthink application installed in the Applications folder.

Try once more to open the database. If the message appears again, can you open it by clicking on the Ignore button? If not, please send a message to Support (Help > Support) describing your problem.

I only have a single copy of DTPO, and no other copies running. So that was not the case.

I tried your suggestion by clicking “ignore” button, and that worked! Thanks.


If there was a freeze or unexpected reboot, DTPO wouldn’t have been able to close the database cleanly and release the lock. There might be other problems – it’s probably a good idea to “verify and repair” the database.

Yes, you are right, there had been a freeze and reboot before this happened. I need to do a “verify and repair”. Thanks.

I’ve just run into the same message, but the “Ignore” option doesn’t work for me. Let me give you the lead-up:

I have Sophos antivirus installed. I have a DevonThink Pro database into which I’ve put alot of webarchives. It appears that I recently put a webarchive into the db that contains what Sophos regards as JavaScript malware. Sophos checks file upon access, so when I tried opening the database, Sophos flagged the ‘DEVONthink-8.database’ inside the database bundle, and automatically moved it into the malware isolation folder I’d designated previously to Sophos. Then the database opened, and the first window looked OK, but I didn’t want to chance having a major file missing while working in the DB, so I shut down DT, then told Sophos not to scan the folder where I keep the DT databases, then moved the ‘DEVONthink-8.database’ file back into the database bundle using the Finder, with a ‘Show Package Contents’ to get at the files inside the database bundle, and replacing a newly-created file of the same name but which was only 4K, IIRC.

But then, after putting the larger '‘DEVONthink-8.database’ file back in the db bundle, when trying to open the webarchive db again, it gave me the ‘already in use’ message; when I hit ‘Ignore,’ the DB doesn’t open up. Nor does it open up hitting the other option.

The ‘DEVONthink-8.database’ is a somewhat large file here – over 180 MB – and I figured that if the JavaScript malware was detected in there, then it must have intact contents of at least some of what’s in the database, rather than being, say, just an index file that can be recreated.

I’m a DT newbie, but know a little about DBs in general; any advice for getting this webarchive DT database to open up again without losing data? (There are 3 backups inside the db bundle, but I’ve added significantly to the db since the last backup, several days ago, and would rather not lose the info.)

Thanks for any pointers; perhaps I need to look around for an overview of what the different files in the db bundle actually are, so I can know better what I might be able to fix, and what not to touch, in the future.

Crikey. You have a problem. You could try copying the DEVONthink-8.database file back inside the package and cross your fingers that it opens.

Seriously, turn off that on-access scanning crap. It’s crap, and it is GUARANTEED (right now, by definition) to cause more problems than it solves. That’s horrible.

CatOne speaks the truth. As soon as you mentioned you were running anti-virus software, I facepalmed.

You have a Database bundle right now – let’s call it #1. Copy your entire database (call the copy #2). Restore #1 from an older copy. Delete the old DEVONthink-8.database from #2 and see if DTP automatically builds a new copy. Then see how much you can get out of #2.

Personally, not that I know anything, but I would not depend on database #2 ever again for anything.

This is a painful lesson in why antivirus software is frequently worse than any virus could ever be.

Yeah, tried that. Then, on restarting DT, that’s when the ‘database is already in use’ dialog came up. Tried both options - ‘ignore’ and the other one, and no joy.

Yeah, I wouldn’t even be running it, but the university just a little while ago started requiring all personal computers that attach to their network have antivir. Even Macs. I imagine even Linux – maybe ClamAV, I don’t know. But you’re right – and I’ve turned it off, for the folder where I keep the DT databases for now, and maybe for the whole machine soon. We’ll see if the University-written kerberos auth software checks for that.

I’m certainly not proud of the incident :~)

I’ll be going that route next, I think. Still, I’d like to know what each of the numbered .database files is responsible for… would it just take a quick search through, say, these fora, or is this arcane knowledge that only gets whispered among the programmers? If ‘DEVONthink-8.database’ is in fact an index file, then I have more hope that it can just be rebuilt from the other .database files et al.

Yup agreed there as well. Sometimes were a bit at the mercy of the powers that be. This recent requirement for antivirus on everything is a pretty drastic reversal from the many-years old policy – and I think that it’s one of those cases where the policy was set to reduce a cost that was easily measurable (the IT office’s budget) at the expense of a difficult-to-measure, but far, far, greater cost spread out and imposed on those of us who depend on the infrastructure.

Anyway, thanks for the quick advice on this; if I learn more as I try to resurrect things, I’ll drop it into this thread.

A followup on my problem described previously in this thread, in which an antivirus program (Sophos) moved part of a DevonThink db file-bundle when opening the bundle/db; when I moved the “DevonThink-8.database” file back into the bundle, the file bundle wouldn’t open, with the message that’s the title of this thread – it wouldn’t open when hitting either button that’s available in that dialog box…

The upshot is that I have a working database, with most or all of the contents recovered, but I have to open it with the file bundle named differently than it was named when it became damaged, or I get the “database is already in use” message again. I don’t know why this is, but my best guess is that DTP has maintained, in a cache or prefs location or something, the name of the original file-bundle with an indication that a database/file-bundle with this name is open. It doesn’t seem to be a property of the database/file-bundle itself. Weird. Or maybe just weird for a newbie like me.

The gory details:

It took a couple of days for me to find time to get back to this issue. In the interim, I’d restarted my Mac. I made a duplicate of the problematic file bundle in the Finder, with the re-inserted “DevonThink-8.database” included. I tried opening it up, and it opened without complaint. I thought that perhaps the restart had closed a file that the OS had mistakenly maintained in ‘open’ status, and the restart of the machine had cleared this. I then did a ‘Tools->Verify & Repair’; at the end of this, it said that there was one file/entry that was damaged, and that it couldn’t repair it.

Then I did a ‘Tools->Backup & Optimize’, and this was mostly successful, except that a few web archives were listed in the log window as having failed to export.

Finally, I did ‘Tools->Rebuld Database…’, and this seemed to work, too.

But then, I quit DTP, renamed the original file bundle to remind me that it was the broken version, and renamed the Finder-duplicated one back to the original name. Then, on double-click opening it (causing a launch of DTP, of course), it again gave me the “database is already in use” message. Hitting ‘Ignore’ opened the db. So I quit DTP, re-renamed the Finder-duplicated file-bundle that had been through the whole process described above, to a name different from the original file-bundle’s name, and it double-click opened without any complaint at all.

Odd, it seems to me. The “database is already in use” message comes up if the copied and fixed file-bundle has the same name as the one that appears to have been damaged by the anitvir software, but all I have to do is rename this file-bundle to something else, and it opens smoothly. I don’t have time at the moment to explore this further; I imagine only a few DTP programmers would know for sure what’s going on.

Thanks again for the advice on this. Still learning.