Database issues - sync & missing files in trash

Help, please!

Pdf index not updating and (~900 files) moved to trash I think during failed iCloud sync to DTTG3.

Here’s how it played out:

  • Downloaded DTTG3 to iPhone, attempted to sync via iCloud,
  • One database (smaller) and Inbox synced successfully, one large database would not sync, even after left over night, even after toggling sync on and off, restarting the app^. I give up, and decide to handle this later, but I notice the database info states there’s ~800 deleted files.
  • Back on DT3 (3.7, Big Sur 11.2.3 (20D91)), I notice my large collection of indexed pdfs is missing around 200 files, updating indexed files doesn’t do anything, yet the files are definitely there in the original location (on iCloud, filled in through Mendeley).
  • I see a similar large number of items in Trash - where I have not placed them, so in the heat of the moment -
  • I presumed something went wrong with the failed DTTG3 sync, and I drag these back into the database so that I can continue working (was this a mistake, and should I have just indexed the folder anew instead?)
  • The move from Trash is completed, but my computer crashes minutes later, while in DT3.
  • Computer restarts, DEVONThink opens, and reports 800+ missing files in database - I choose ‘Reveal’ (if I remember the option correctly), and see they are the trash files I moved 5mins earlier. But my database doesn’t open.
  • After a couple of attempts, the database does open, log shows gazillion missing files (from Trash), I now have two groups indexing the same folder on iCloud, with a ~200 file difference between them (and info states they were created two days apart back in April, which makes no sense to me) BUT neither will update when I go to File > Update Indexed Items.

On the other hand, annotations I’ve made previously in the day and yesterday while on iPad are all visible in DT3, even before I ran the update, so the link with original location of files on iCloud does work, but for some reason not all of the files are indexed and the log doesn’t show anything at all when I try to update (tried selecting the group as well).

What am I missing here?

^ I’ve had no problem doing this on iPad, and iPhone storage isn’t an issue.

Hold the Option key and choose Help > Report bug to start a support ticket.

1 Like