database permissions - howto?


Trying to solve some issues. Not only / specifically DTPO.
Often times it is handy to simply create a new user account in OS X, assuring that you work from scratch.

I did this today:

  • created new user, member of admin
  • shared my /User/erwin/Documents/DT files with newly created user
  • fired up DTPO
  • tried to open my own DB but logged in as ‘new user’

This failed obviously because of permissions.
I did ad read/write permissions to the staff group (both users are member)
Still doesn’t work.

What should de permissions be to allow this to work?

Thx for helping out!

Failed how?
Didn’t open?
Received a warning?
Computer exploded? :mrgreen:

Just before the explosion… :blush:
After clicking “Continue”

04/04/2016 20:03:02.150 taskgated-helper[4169]: Failed reading data: Error Domain=NSCocoaErrorDomain Code=260 "The file “embedded.provisionprofile” couldn’t be opened because there is no such file." UserInfo=0x7fd74cb01280 {NSFilePath=/Applications/DEVONthink, NSUnderlyingError=0x7fd74cb00d90 "The operation couldn’t be completed. No such file or directory"}
04/04/2016 20:03:13.336 DEVONthink Pro[4167]: assertion failed: 14F27: libxpc.dylib + 62447 [5C829202-962E-3744-8B50-00D38CC88E84]: 0x89


Is the database open in the other account? If so, it can’t be. DEVONthink databases cannot be simultaneously accessed.


No the database is not open in the other account.
I have been cautious to avoid that.
Specifically re-tested, 1st user logged out, DTPO, 1st closed DB, then quit DTPO.

Will now try to copy DB to 2nd user home dir.

Copying DB and opening in 2nd user home dir allows to open now…
No more error.

Hmm, it seems to point in the direction of iOS (embedded.provisionprofile)
I found my system has a /Users/Shared directory, it contains amongst others files from text expander. (I seem to remember that you can set it up for all users or a single user, maybe that has to do with it)

Moving the DB to the /Users/Shared folder changes the group ID to wheel instead of staff.
But I get the same error of the DB already being open as before…

I’ll await insights from the mighty men :bulb: :laughing:

Permissions in OS X are not Apple’s finest achievement.

I would do a sudo chmod -R 777 in Terminal and drop the database into the window.

FWIW, I think this is equivalent to an issue that just came up for me as well using Curio … … 300/1073/9

The hint may be how a file is written to a Shared folder depending on which user opens it.

In a nutshell … The chmod -R 7777 may only work once, then fail after you open your database with the other user ID. The recommendation at that point from the developer of Curio is, I may have to use ACLs. I have yet to try an option where I in some way open the file via a symlink to the file instead of opening the actual file.