Database won't copy

I have a Devonthink 3 database on an external drive. It works fine. I want to move it however and each time I try to copy to my Mac it gets stuck at the same point – 17.15gb through copying 17.7 gb. I have verified and rebuilt the database but still the same result. Is there anything else I can try?

It could be any number of things unrelated to DEVONthink, that I can think of–but few of those are debuggable from here. However, I’d first try with that database to File/Export the database to an archive (a zip file), copy that zip file to your Mac, then restore it in place. A single Zip (vs. thousands of files in teh database) file may overcome some of these other issues with copying across a wire. Full instructions for doing his are in the DEVONthink Manual (and in Help, which holds same content).

Thank you and sorry I should have mentioned – I did try that (Export the archived database) but had the same problem: it gets most of the way there and then just hangs.

Just feels you have a hardware/software problem with big transfers. Of course I could be, and probably am, wrong. What if you connect the external device to a different computer? Or you sync it to another computer/device, then copy from that device?

Or the database and/or archive file is corrupted in some unknown way (but you said you had done a DEVONthink verify).

May not make a difference, but I’d try it anyway. In Finder, use the “Compress” feature to compress the database package to a zip, then copy that zip and use Finder to uncompress the package.

I’m nervous about messing round with the one good copy I have. I did just now try to duplicate it where it is in order to try what you suggest (compress then move) – but duplication runs into exactly the same problem as moving – it gets most of the way and then just keep spinning - never completes the duplication.

Stupid question: Does your Mac have enough space for the roughly 18 GB?

1 Like

Compressing it won’t modify the source.

Another idea that I’d do: do a Repair on both disks (external and your Mac) with your Mac’s Disk Utility.

Yes - 147gb available.

1 Like

Last idea I have: On your Mac, create a new empty database. Open that new data base and the database on the external drive (you say you can). Drag and drop, a group or two at a time, from the database open on the external drive to the empty database on the Mac.

Hopefully everything comes across. But by doing it by one or two groups at a time, you might find the offending files. Or it might just go all ok.

After done, then run a Repair on the external drive (if not done already). [External drives are sometimes prone to corruption–real or perceived–due to the Mac thinking they were disconnected improperly].

1 Like

OK I’m so grateful for your help! I ran the First Aid on Disk Utility and yes on the external drive it said it found problems it could not repair. Then I saw your latest message. I created a new Devonthink database on the main computer and transferred the folders in small groups – and it worked, all are now safely across. Thank you for that brilliant solution!